Jump to content
  • 0

Freezing from day 1


Question

Hi guys, Przemo form Poland here. I have a problem, Since i bought  Pillars of eternity on Steam i cannot play it because GAME FREEZES on loading screen after defeating enemies in first camp, after electric storm. Every time - i can play only to this moment ( i must admit that i love this game and want to play more than 10mins) Next thing is i cannot save the game. 


I need your help so much.... I read hundreads of topics on forums, searched everywhere, changed on beta version, checked/veryficated files on steam


Is there a chance to fix this problem ?  I have win7 64 bit, 6gb ram  cpu3ghz, gtx 760 2gb 256bit PLEASE HELP 


 

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Have you tried turning steam cloud off for this game?

 

Not saying this will fix it for sure, but I had a similar issue and the cause was the size of the saved games files were taking to long to upload to steam's cloud.

 

To enable/disabled Steam Cloud:

Go to Library > Right click Pillars of Eternity -> Properties -> Updates tab -> Steam Cloud

Link to post
Share on other sites
  • 0

The default location for the output_log on Steam versions of PoE should be C:\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\output_log.txt.

 

The "MUST READ..." thread gives details on getting a dxdiag file (the DirectX Diagnostic which provides thorough details of your system). Save this file somewhere where it will be easy to retrieve like in C:\.

 

To attach a file, click on "More Reply Options" under the quick reply box to take you to the full reply screen. There will be an "Attach Files" section with 2 boxes, each with a "Choose" button to their right. Click on the first button to bring up a file selection box, use that to select the output_log.txt. Click on the second and use that selection dialog for dxdiag.txt (which should be C:\dxdiag.txt if you followed the advice above).

Link to post
Share on other sites
  • 0

Thanks for posting the DirectX file - that has highlighted two possible issues. You don't seem to have proper graphics drivers installed for your Nvidia GeForce GTX 760 (no date is given) so you should get the latest Forceware drivers from Nvidia. Secondly, your audio drivers are dated (2009 vintage) so updating these might be a good idea also.

 

The file also shows you are running a Polish 64-bit version of Windows, so the output_log.txt file should be in C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\output_log.txt - the full path can vary depending on Windows version which is why that DxDiag file was so important.

 

Link to post
Share on other sites
  • 0

Hi again, im attaching output_log and dxdiag again .......now,  what i have done: instaled newer drivers for audio, motherboard chipset and latest version ogtx760 drivers (still theres no info on dxdiag.txt about display drivers-  although i had a problem while instaling nvidia drivers -  installer failed once, second - this was happening all the time so i removed/uninstalled manually older drivers and pointed a path to the newest drivers(before this failing instalations it extracts to nvidia folder all data) - now in device manager i have latest version so i think they have been updated. BUT the game isnt working properly - sill: i cant save at any moment, i cant pass the "loading screen" after electric storm (freezed forever - once i waited 2h - nothing)

Please help. What else i can do ?

output_log.txt

DxDiag.txt

Link to post
Share on other sites
  • 0

Nvidia driver dates are still not showing in DxDiag.txt - given you have reported an error during installation I would suggest you need a "clean install" by doing the following:

  • Download Display Driver Uninstaller;
  • Disconnect from the Internet (to prevent unwanted auto-updates) and restart Windows in Safe Mode;
  • Run Display Driver Uninstaller - select "Nvidia" and "Clean and restart";
  • Once Windows restarts, it will likely prompt you multiple times about detecting new hardware - skip any prompts. You will also likely have a far worse-looking display - that should be fixed in the next step;
  • Run the Forceware driver you downloaded earlier - when prompted for a path initially, just point it at your Temp folder (it will always install in C:\Program Files\NVIDIA Corporation whatever you specify);
  • Once the driver has installed, it should restart Windows - once restarted, your display should be back to normal. At this point, you should be able to reconnect to the Internet.
TweakGuides has a more extensive guide to doing a clean install, should the above steps not work or if you need more explanation. Edited by AstralWanderer
Link to post
Share on other sites
  • 0

didn't work - although i'm sure about graphic drivers - attached psc.jpg shows info from two sources (350.12 are latest form nvidia for gtx760)  - dxdiag don't show it - its verry interesting but is there a chance it is the problem? thats why game fereezes all the time? i dont think - i reinstalled game yesterday, this also didnt help. PLEASE HELP - i dont know what to do next. Can someone give me next idea, I think that hte official Obsidian forum is the best place to ask for help am i right? I want to play in this cool game !! Or give my money back i say :p 

post-152237-0-34721200-1430387233_thumb.jpg

Link to post
Share on other sites
  • 0

Actually, the picture shows they're both the same version (9.18.13.5012 is how Nvidia numbers their 350.12 drivers). It should show also on the DxDiag report and the continued lack of such data suggests something wrong on your system (do any other games or graphics benchmarks like 3DMark or Unigine Heaven or Valley show any problems?).

 

There is something else to try and that is to modify the shortcut you use to start Pillars of Eternity. My suggestion would be to make a copy of that shortcut on the desktop (even if you already have one, make a second) and to modify it as follows:

  • Right-click on the icon and select Properties;
  • There should be a Target box showing the location of the PoE executable - in your case it should be something like "C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity.exe";
  • Add -force-d3d11 to the Target box, so it ends in ...PillarsOfEternity.exe" -force-d3d11
  • Try running this shortcut.
If that doesn't work, change -force-d3d11 to -force-opengl and try again.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...