Jump to content
  • 0

[Bug] In Raedric's hold - after freeing Giacco, missing dialog option with Nedmar



*Update: Nevermind, problem resolved*


I seem to be missing a dialog option when talking with Nedmar in Raedric's Hold Sanctuary. I have freed Giacco, returned to Nedmar, but the this is what Nedmar says to me now:


Nedmar- "You've returned! Have you found him? Are there any survivors?"


1: "I need to rest."

2: "Goodbye."


I was expecting an available reponse such as, "I freed Giacco. Now please show me how to get into Raedric's personal sanctuary next to the throne room."


I exited the game and loaded it back up and I get the same dialog options from Nedmar.


I also tried choosing the "I need to rest" option and then talking to him again, but same thing.


I got into the keep through the sewers, through the jail where I opened Giacco's cell and told him to stay put. I killed Osyra, went up to the ramparts and killed some mercs/guards, went back to dungeon/crypt, went upstairs to kitchen, went upstairs to sanctuary, put on robes, sweet-talked my way past all the staff, talked to Nedmar and we agreed that I would free Giacco and then he would get me into Raedric's personal sanctuary located beside the throne room. I went back to Giacco's cell, told him that Nedmar sent me to free him, told him that I'd killed Osyra and that he should leave Raedric's hold. Then he walked off. I went back to Nedmar and I don't have an option to tell him I freed Giacco.


I can't upload my save game because it's too large. I also tried to split it using 7-zip so that I can upload it in two chunks, but I get an upload error saying I am not allowed to upload that file type (.zip.001 and .zip.002).





I'm playing with the Steam version of Pillars fo Eternity, which updated yesterday.


*Edit 2*

I forgot to include the status of the quest in my journal:


- Confront Lord Raedric the VII inside Raedric's Keep.   Day 19, Hour 15.   17 Fonprima, 19755 AI


I have reached Raedric's Hold. Lord Raedric waits somewhere within, but making my way inside will not be a simple task.


I've spoken with Nedmar, the high priest. He promised to grant me safe access to Raedric's throne room if I manage to free his former acolyte, Giacco, from the keep's prisons in the lower dungeons.


I've found some Berathian robes. They may help me blend in with the priests on this floor.


Yes it appears to be missing the part about me freeing Giacco and killing Osyra.


*Edit 3*

I went back to check the cell again and Giacco is back in it... I freed him again and my journal updated with that fact. Nedmar now gives me the correct options.

Edited by BanjoBlack
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...