Jump to content
  • 0

Linux: In the darkness


bidule

Question

Hi,

 

Thank you for making this game, and supporting GNU/Linux.

 

I have the gog.com Hero edition (gog_pillars_of_eternity_1.0.0.1.tar.gz).

Everything worked fine until the game really start. The game background is not rendered at all, characters are just highlight a little.

The UI part fork fine except the local map.

 

I just give a try on the windows version (Win10), and it worked fine.

 

My system:

  • OS: Ubuntu GNU/Linux 14.04
  • Linux kernel: 3.19.3-custom / 3.13.0-48-generic
  • Driver: mesa 10.6 git (ppa xorg-edgers)
  • CPU: Intel® Core™ i7 CPU 920 @ 2.67GHz × 8
  • RAM: 8Gb
  • Video: AMD Radeon HD6850 (Barts) / 1Gb of VRAM
$ lspci -v -s 02:00.0
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850] (prog-if 00 [VGA controller])
    Subsystem: PC Partner Limited / Sapphire Technology Device e174
    Flags: bus master, fast devsel, latency 0, IRQ 69
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at f3ec0000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at c000 [size=256]
    Expansion ROM at f3ea0000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
    Capabilities: [150] Advanced Error Reporting
    Kernel driver in use: radeon
$ dmesg | grep VRAM
[   18.987615] radeon 0000:02:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[   18.987619] [drm] Detected VRAM RAM=1024M, BAR=256M
[   18.987701] [drm] radeon: 1024M of VRAM memory ready
I have a dual monitor, but since the game want to only run in fullscreen on the left monitor (a 1280x1024 one), and not on my main monitor (1680x1050), I have modify the start.sh script to disable one monitor:

	xrandr --output HDMI-0 --off
	
	execute_game "${bin32_name}" "${bin64_name}" "${bin_path32}" "${bin_path64}" "${lib_path32}" "${lib_path64}"
	
	xrandr --output HDMI-0 --auto
	xrandr --output HDMI-0 --left-of DVI-0
The commands after "execute_game" are here to restore my original configuration, after the game quit. I use the same trick with "Wasteland 2" (gog version too).

 

The forum give me an error while attaching the Player.log & screenshots files, so here a past:

https://framabin.org/?b4c6c66c68a60f2a#D/4Vp7HedOMFcbgJc4WiG8moyrtkwv90AH7h9YOXCjo=

 

I see 2 strange things mainly in the log:

GL: Detected 30 MB VRAM
and

WARNING: Shader Unsupported: 'Trenton/PE_BackgroundPassMRT' - Pass '' shader state not supported
WARNING: Shader Unsupported: 'Trenton/PE_BackgroundPassMRT' - Setting to default shader.
Screenshots:

http://hpics.li/0c48615 mini_167039PoEgame.png

http://hpics.li/454fd87 mini_455508PoEinterface.png

http://hpics.li/3b666d5 mini_376957PoElocalmap.png

 

Thanks for your time.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi,

 

I have installed on another partition Ubuntu 14.10, and update it.

The game works fines (at least it display normally). I will still wait a little before starting playing it, the time the most annoying bugs, reported in the forum, are fixed.

 

I have some bleeding edge software & driver, on my Ubuntu 14.04 doesn't help. Must be a driver regression.

That's a problem you may have, when using drivers in development :getlost: .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...