Jump to content
  • 0
Mageoftheyear

[Is this a bug?] Running PoE as Administrator Prevents Steam Overlay Working

Question

Description & Steps to Reproduce the Issue:

 

The Steam Overlay will not open if the PillarsOfEternity.exe is Run as administrator. This is true whether the "run as admin" function is set in the exe's Properties or if "run as admin" is selected by right clicking on the exe. The problem persists whether at the main menu or in-game.

 

When admin is set via properties and the game is run via steam v1.0.2.0508 -steam is displayed in the lower left-hand corner. Running the exe directly (by double clicking) only v1.0.2.0508 is displayed.

 

When admid is set by right clicking on the exe only v1.0.2.0508 is displayed.

In all three cases the overlay will not work.

 

What I tried to do to fix it - TL-DR: I failed:

 

[After a bit of browsing I thought I'd try the method below to get both working simultaneously. I thought I had it working but upon validating the process in task manager (here's a how to) I could see that PoE was in fact NOT running as administrator:]

  •  Find Pillars of Eternity via Steam (the program, not the installation location), right click and select Properties
  • A window will open on the GENERAL tab (make sure you have the Enable the Steam Overlay while in-game option checked)
  • Select the SET LAUNCH OPTIONS... button and in the Launch Options window that appears type in -forceservice and select the OK button. If you have any other commands in here make sure to leave a space between them (found this command here.)
  • Close the Pillars of Eternity - Properties window and launch the game through Steam.
  • The lower left-hand corner of the screen will now read: v1.0.2.0508 -steam -forceservice

Now you're running as admin and get to keep the Steam overlay to boot! Enjoy!

 

After four hours of research I'm done. Sadness, I have newb'd. Sadness lives in my soul. ;(

 

:banghead:

 

Info for devs:

 

As this is not a crash I didn't include any savegame files, output logs or screenshots. Let me know if there is any more info that'd help you. I have included my system specs via dxdiag (as well as the 64-bit dxdiag) and just in case you need it here is my Steam version info:

  • Built Mar 23 2015, at 20:07:51
  • Steam API: v017
  • Steam package versions: 1427176184

System Spec links:

https://drive.google.com/open?id=0B5-ClpK5zHyfMzR6MndJc3hvNmc&authuser=0

https://drive.google.com/open?id=0B5-ClpK5zHyfZlYyQjZVUEJSYmM&authuser=0 (64-bit version)

 

-----------------------------------------------------------------------------------------------------------------------------------

 

Oh by the way, I just wanted to take the opportunity to thank the entire team at Obsidian for this amazing game. I've barely scratched the surface and I love it already. I've never played any of the old CRPGs but I backed anyway. The fact that you guys have a splash screen thank you for your backers every time the game starts off is pure awesome. Thank you for that!

I know there are mainstream haters out there looking for any excuse to write this game off because it doesn't fit in their "clique" of what "gaming should be" - to hell with 'em. Gamers know what this game is worth and stuffed coffers speak loudest. :thumbsup:

 

I'm so proud that PoE is getting the limelight it deserves.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

That's pretty weird indeed, I tested it myself and run it as admin, overlay worked just fine (tested by taking sceenshot with steam), you sure you are not running something like Fraps? As in some games it will break Steam overlay.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

This sounds like something that would happen due to Microsoft Windows' User Account Control which is meant to prevent other programs from 'drawing' overtop of the escalated program.

 

As a workaround I would suggest that you set UAC in Windows to the lowest level, reboot, and then steam overlay will also be running escalated (as will all programs that you run).

 

It's not a perfect workaround but I think it will do the trick.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

you sure you are not running something like Fraps? As in some games it will break Steam overlay.

 

Very sure. Besides seeing Fraps was a common theme in this problem, I went over my processes stack with a fine-tooth comb.

I thought Steam's FPS counter might be the problem but whether on or off (after restarting the PC) the overlay just refuses to launch while PoE is running in admin mode.

 

 

This sounds like something that would happen due to Microsoft Windows' User Account Control which is meant to prevent other programs from 'drawing' overtop of the escalated program.

 

As a workaround I would suggest that you set UAC in Windows to the lowest level, reboot, and then steam overlay will also be running escalated (as will all programs that you run).

 

It's not a perfect workaround but I think it will do the trick.

 

I'll try that. Brb.

 

EDIT: Yup that did it!  :w00t:  Even works with the Steam FPS Counter too. Thanks!

 

Thing is though... I saw 0% performance improvement from running in admin mode, so ugh... it doesn't look like I'll be using your fix then lol. Thanks anyway. :facepalm:

 

But in case it helps someone else (and in light of your test working) is there no other way to give PoE a free pass to run as admin without nerfing UAC for all of Windows 7?

Edited by Mageoftheyear

Share this post


Link to post
Share on other sites
  • 0

 

you sure you are not running something like Fraps? As in some games it will break Steam overlay.

 

Very sure. Besides seeing Fraps was a common theme in this problem, I went over my processes stack with a fine-tooth comb.

I thought Steam's FPS counter might be the problem but whether on or off (after restarting the PC) the overlay just refuses to launch while PoE is running in admin mode.

 

 

This sounds like something that would happen due to Microsoft Windows' User Account Control which is meant to prevent other programs from 'drawing' overtop of the escalated program.

 

As a workaround I would suggest that you set UAC in Windows to the lowest level, reboot, and then steam overlay will also be running escalated (as will all programs that you run).

 

It's not a perfect workaround but I think it will do the trick.

 

I'll try that. Brb.

 

EDIT: Yup that did it!  :w00t:  Even works with the Steam FPS Counter too. Thanks!

 

Thing is though... I saw 0% performance improvement from running in admin mode, so ugh... it doesn't look like I'll be using your fix then lol. Thanks anyway. :facepalm:

 

But in case it helps someone else (and in light of your test working) is there no other way to give PoE a free pass to run as admin without nerfing UAC for all of Windows 7?

 

I guess if you could get the steam overlay to be running as admin it could work without turning off UAC, but I'm not sure on which executable or service you'd have to flag to always run as admin or start as a particular service account. I'm also not sure if then that would affect your steam settings due to possibly running under a different Windows user account profile/environment.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I guess if you could get the steam overlay to be running as admin it could work without turning off UAC, but I'm not sure on which executable or service you'd have to flag to always run as admin or start as a particular service account. I'm also not sure if then that would affect your steam settings due to possibly running under a different Windows user account profile/environment.

 

Thanks for the tip! I'll see where it leads.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...