Jump to content
  • 0

Character customization bug - No portrait


MonsieurJZ

Question

Hey folks,

 

It seem I have bug during the character creation at the customization step, instead of portraits I have a big red question mark displayed as you can see below. I pre-loaded the game on Steam this afternoon and already checked the game files.

 

Am I the only one that experimenting this issue ? If not, how did you solve that ?

 

Thank for your help :-)

 

XPsWUa.png

Link to comment
Share on other sites

19 answers to this question

Recommended Posts

  • 0

My issue is solved, I had to re-install Steam and Steam library in the same folder to fix this glitch. To resume, everyone that had this problem solved it by using one of those solutions :

 

1- Run the .exe with the option "Run as administrator"

2- Translate the folder names in english if you are not using latin alphabet

3- Check if everything is OK with picture names in /steam/steamapps/common/Pillars of Eternity/PillarsofEternity_Data/data/art/gui/portraits/player/(female or male)/

4- Re-install Steam library and the game in the original Steam folder on the same HDD

 

Thank everyone for your help and enjoy your gaming experiences :biggrin:

Edited by MonsieurJZ
  • Like 1
Link to comment
Share on other sites

  • 0

I tried to uninstall / re-install the game but that still doesn't work.

 

Do you have any images in steam/steamapps/common/Pillars of Eternity/PillarsofEternity_Data/data/art/gui/portraits/player/(female or male)/

 

Yes, all pics seem to be here.

Link to comment
Share on other sites

  • 0

Do you have any images in steam/steamapps/common/Pillars of Eternity/PillarsofEternity_Data/data/art/gui/portraits/player/(female or male)/

I also have them in there.

Link to comment
Share on other sites

  • 0

Then I dunno, sorry! Just figured I'd point out the one obvious thing that it might be.

 

Ty anyway :)

 

Same issue as the OP. During character creation, all portraits are a red question mark with a white background. In-game, its still like that, but just for the player character.

 

Unfortunately I found an other character in-game that neither have portrait.

Also, is it normal to get no ambiant music at all ? Neither in combat ? I only get sound effects...

 

It's like the game were not able to find any content in data library... I'll wait to play the game till a patch fix all those issues because that ruin the experience. :(

Edited by MonsieurJZ
Link to comment
Share on other sites

  • 0

Well i have an update. In the starting area, my character didn't have a portrait. Not did he have a portrait during character creation as well. The first (tutorial) companion, Calisca, had a portrait just fine.

 

Now that i have reached the Gilded Vale, met Aloth, and had him join me, he doesn't have a portrait either. Here are 2 screenshots showing the problem.

 

 

image.jpg

 

image.jpg

Cogito ergo sum. Ex astris scientia.

Link to comment
Share on other sites

  • 0
Unfortunately I found an other character in-game that neither have portrait.

Also, is it normal to get no ambiant music at all ? Neither in combat ? I only get sound effects...

 

It's like the game were not able to find any content in data library... I'll wait to play the game till a patch fix all those issues because that ruin the experience. :(

 

 

As far as sound goes, i haven't experienced any kind of sound problems yet. I get music, ambient, effects and combat sounds just fine. Nevertheless, i am seeing other people on the forums that have.

 

Try and tamper with your sound settings in the options menu, like change things around and move the sliders, and see if that helps at all.

Cogito ergo sum. Ex astris scientia.

Link to comment
Share on other sites

  • 0

starting the game .exe from the game folder (\SteamLibrary\steamapps\common\Pillars of Eternity for steam) as an administrator fix the red question mark portrait for me 

 

Thank you, unfortunately that doesn't work for me. I think I will try to re-install Steam and the game on my first HDD.

 

Thats very annoying bug.

 

As you say it starting to get ankward, no way to play for me without killing the whole game experience. I am waiting for a patch or a temporary solution at least.

Link to comment
Share on other sites

  • 0

Hi!
I'm new posting on forums, so sorry if this post is wrong or whatever.
I'm not good writing/speaking english, so I want apologize if i have some gramatical errors. Thanks.

Some years ago I did the change with some problems like this on Baldur's gate. So I would like to help with my little experience on it.

Could be a stupid question but...Did you tried to change the picture name to a just 8 letters's name followed with _sm.png and _lg.png? I mean, something like "Frodo_lg.png" and "Frodo_sm.png". I dont tried yet to change my portraits, but I will. 

I'm just suggesting. Thanks anyway and sorry again.

Link to comment
Share on other sites

  • 0

Ok. I solved issue. The bug itself connected to pathway to .exe (like \SteamLibrary\steamapps\common\Pillars of Eternity). It seems if SteamLibrary folder located within folder with not english letters (like cyrillic in my case) in name bug pops up. So you must rename all not english named mother folders and problem solved.

Sry for my english.

Edited by Chessbrain
  • Like 1
Link to comment
Share on other sites

  • 0

Hi!

I'm new posting on forums, so sorry if this post is wrong or whatever.

I'm not good writing/speaking english, so I want apologize if i have some gramatical errors. Thanks.

 

Some years ago I did the change with some problems like this on Baldur's gate. So I would like to help with my little experience on it.

 

Could be a stupid question but...Did you tried to change the picture name to a just 8 letters's name followed with _sm.png and _lg.png? I mean, something like "Frodo_lg.png" and "Frodo_sm.png". I dont tried yet to change my portraits, but I will. 

I'm just suggesting. Thanks anyway and sorry again.

 

Get this one too few years ago. :)

Unfortunately I don't think that come from file names because I didn't change anything in original library. Otherwise that should mean everyone get this glitch and it doesn't seem to be the case.

 

Ok. I solved issue. The bug itself connected to pathway to .exe (like \SteamLibrary\steamapps\common\Pillars of Eternity). It seems if SteamLibrary folder located within folder with not english latters (like cyrillic in my case) in name bug pops up. So you must rename all mother folders with not english latters and problem solved.

Sry for my english.

 

I am currently making a clean install of Steam and PoE in the same folder ; indeed it seem to be a pathfinding issue. I will try your tip asap and keep you updated although I only use alphabetical letters.

 

I really hope that will work this time ; thank all for your support and enjoy the game by the way. ;)

Edited by MonsieurJZ
Link to comment
Share on other sites

  • 0

well in my case i had added (male_) or (female_) on each file name then it appeared on the game... the only hassle is i needed to change ALL of them... transferred IWD portraits on my folder...

 

anyone who can help me with this? very lazy to change file names one by one 

Link to comment
Share on other sites

  • 0

Thanks guys.

 

So I guess the problem is with the special characters. In my case, I installed it in my steam directory, which is in #Games directory. I use the # prefix so I have the most important folders right at the top.

I installed it in a folder without any special characters and now it works and my character has ugly guy as a portrait:D

 

I wonder if it's a problem of a Unity engine. Shadowrun Returns also runs on Unity and at the launch I had a similar problem, even though it was much worse. In the case of SR I didn't see a menu, so I couldn't do anything. Installing in a directory without special character also helped in that case.

 

Interesting thing.

 

Anyway, back to that lovely game <3

 

Have a nice days with PoE:P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...