Jump to content

HELP! Can't run kotor 2


Recommended Posts

Hello, to anyone that can help. I've tried everything I possibly can to get kotor 2 running and it just won't work! Here are the specs for my computer:

 

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)

DirectX Version: DirectX 11

System Model: Aspire 5742

BIOS: InsydeH2O Version V1.03

Processor: Intel® Core i3 CPU

 

Display Devices

---------------

Card name: Intel® HD Graphics

Manufacturer: Intel Corporation

Chip type: Intel® HD Graphics (Core i3)

DAC type: Internal

 

Installation worked fine, and everything runs fine until I finish character creation, the intro scene plays, and just as the T3 start scene begins, i get a message that says "KOTOR 2 has stopped working" I've tried running it in compatibility mode, installing it in capability mode, EVERYTHING! This is my last resort but I'm desperate, I loved this game.

 

Any solution would be well appreciated.

Link to comment
Share on other sites

I *think* the problem comes from your graphic card. Kotor 2 doesn't seem to like Intel graphic cards, not many games do to be honest...

I searched Google, this issue is not uncommon and seems to invariably affect those using Intel GPUs.

 

I found this:

"EDIT #6 If you have an Intel GPU:

1) Open your Intel graphics driver's control panel and Click on "3D Options". Look for "Flipping Policy" and change it to "Blit".

here: http://www.lucasforums.com/showthread.php?t=194324 (read the first two posts entirely)

 

You can always try things like:

- installing the patches: 1.0a AND 1.0b in that order (http://lucasarts.com/support/update/kotor2int.html)

- add the line "Disable Vertex Buffer Objects=1" under "Graphics Options" in swkotor.ini (known as the "Dantooine lag fix")

- reinstall graphic card drivers

 

Check this thread also: http://forums.obsidian.net/index.php?showtopic=50140

 

Good luck!

Edited by Togruta
Link to comment
Share on other sites

I have used the site you are linking to before coming here for the fix, i have put that line in the swkotor.ini file already, i did everything in the fix, except the step with the graphics card, this is because my hd graphics processor does not take me to the "3D Options" part that was referred, i have tried looking for older drivers to download, but none are compatible with my i3 processor,

 

I will try the other steps you mentioned and report my findings.

 

Thanks for the help so far, very fast responses.

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

 

Did you think to run K2 in monocore mode and in XP SP3 mode ?

 

You can also try this :

I notice that, for me, K2 runs better in windowed mode.

 

Edit swkotor.ini

Find [Graphics Options] section

Put FullScreen= to 0 instead of 1

 

TTLan

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...