Jump to content
  • 0
Sign in to follow this  
riZla

Strange FPS drops during gameplay

Question

Hello, ive finally got A.P. working after fighting with it for 1hr on my 64bit system..

 

problem im having is as im playing i keep getting fps drops especially in big areas. sometimes if i spin camera quickly it will freeze.. jus like pausing a counterstrike server. but the games still going on (results in camera generally pointing down or somewhere stupid) lol.

 

I know for a fact I shouldnt be experiencing this on my rig as its well above requirements

 

Tried lowering gfx settings to 1440x990 (think its 990 anyways) basically the 10 : 9 aspect ratio below 1680x1050 and still no joy..

 

Tried rolling back gfx drivers and running it then running again after re-updating drivers to no avail.

 

 

 

PC specs:

 

CPU: Intel i7 950 3.06ghz running @ 4.00ghz

Ram: XMS3 6gb Tri-channel 1600mhz

GFX: 2x SLI GTX460 768 (voltage tweaked/OC'd to around 1ghz core clock per card)

PSU: 850watt corsair TX

 

Note: tried running with all the components on stock too. which leads me to believe its a problem with the game design graphically in general. -- (run game via steam so its patched to latest version)

 

Any ideas? :huh:

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
Hello, ive finally got A.P. working after fighting with it for 1hr on my 64bit system..

 

problem im having is as im playing i keep getting fps drops especially in big areas. sometimes if i spin camera quickly it will freeze.. jus like pausing a counterstrike server. but the games still going on (results in camera generally pointing down or somewhere stupid) lol.

 

I know for a fact I shouldnt be experiencing this on my rig as its well above requirements

 

Tried lowering gfx settings to 1440x990 (think its 990 anyways) basically the 10 : 9 aspect ratio below 1680x1050 and still no joy..

 

Tried rolling back gfx drivers and running it then running again after re-updating drivers to no avail.

 

 

 

PC specs:

 

CPU: Intel i7 950 3.06ghz running @ 4.00ghz

Ram: XMS3 6gb Tri-channel 1600mhz

GFX: 2x SLI GTX460 768 (voltage tweaked/OC'd to around 1ghz core clock per card)

PSU: 850watt corsair TX

 

Note: tried running with all the components on stock too. which leads me to believe its a problem with the game design graphically in general. -- (run game via steam so its patched to latest version)

 

Any ideas? :huh:

 

First did Steam really update the game? Or is the update on steam already? If not install it from here:

 

http://help.sega.com/index.php?_m=knowledg...kbarticleid=865

 

(The Digital Download Version)

 

Then apply the ini fix described here

 

http://forums.obsidian.net/index.php?showtopic=55163

 

My mouse is jerky / camera stutters when moving mouse.

This seems to be related to the frame rate and loading environments, rather than the mouse itself. Most people have reported some to complete success with the following methods:

  • Try setting mouse sensitivity in the in-game options.
  • Try editing APEngine.ini (C:\Users\username\Documents\Alpha Protocol\APGame\Config) to the following:
    MinSmoothedFrameRate=20
    MaxSmoothedFrameRate=30
    Adjust the values to suit.
  • Try editing APEngine.ini to the following:
    UseBackgroundLevelStreaming=false
    OnlyStreamInTextures=true
    OneFrameThreadLag=False

 

If you still have problems, check that the .inis have not reverted to their original settings after you have run the game. You might need to set it as 'Read Only'. Always keep a backup of .ini changes, so that if they cause other problems they can be 'rolled back'.

Edited by C2B

Share this post


Link to post
Share on other sites
  • 0

ignore post was looking at wrong directory, trying fix now :huh:

 

Nope, slightly improved but not playable still..

 

any other suggestions?

Edited by riZla

Share this post


Link to post
Share on other sites
  • 0
ignore post was looking at wrong directory, trying fix now :huh:

 

Nope, slightly improved but not playable still..

 

any other suggestions?

 

Did you check it to be read only? Look if the values have changed again.

 

Also

set bEnableMouseSmoothing=False

in \Alpha Protocol\APGame\Config\DefaultInput.ini

Share this post


Link to post
Share on other sites
  • 0

tried all the above including mouse smoothing now.. even tried v-syncing on/off to no effect.

 

although it isnt AS bad, but maxsmoothed frame rate at 30 does make it slow in general/unplayable as if im on the xbox360 version lol.

 

so Ive had to hike it up to 50/60. - this hasnt increased the juttering any tho its stayed at its decreased amount since changing the background streaming etc.

 

(all is read-only and i can tell are taking effect due to extended loading times + feel of the game)

 

Any further suggestions?

 

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...