Jump to content
  • 0
Sign in to follow this  
nobalga

A fix for surround sound (windows 7)

Question

This seemed to work for me, go to my Documents \Alpha Protocol\APGame\config

open the APEngine.ini and scroll down to the [ALAudio.ALAudioDevice] section.

 

Change the line DeviceName=generic software to device name=generic hardware.

 

I have an X-fi so changed it to

DeviceName=SB X-Fi Audio [0001]

you can dl a program called ALcapsviewer from creative that will show you your ALaudiodevices and the id string you can enter instead of generic hardware.

I also increased the maxchannels to 128.

 

I haven't played it much since I changed it, but I am getting 7.1 surround sound, and I can hear conversations much clearer, and I get echo and other effects, but cant confirm its a crash free solution.

 

The issue seems to be that the setup doesn't detect the openal sound devices correctly and just defaults to software

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

The only problem seem to be with bullet impact sounds shot by the player.

 

They seem to originate at the player location, and not where bullets hit.

Share this post


Link to post
Share on other sites
  • 0

I tried it but it does not work as it should

 

it just links the rightfront speaker with the rightback speakers and the same for left, no real surround sound


The Chaos Theory

Share this post


Link to post
Share on other sites
  • 0

This isn't just an obsidian problem, I have played quite a few unreal engine based games and prety much all of them have an issue detecting sound hardware.

 

Thats how I knew about the fix, had the same issue wiyh both mass effects.

 

I can confirm that for me it seems ok, yes maybe some bullet sounds are a bit dodgy, but I am getting sound out of all 7 speakers and the sub. And not just stereo upmixed to surround, I can hear people coming from different directions, but I will agree it isn't perfect.

 

My log files don;t show anything but, log started, logged stopped after about 1 second, for mass effect you could see that the sound was correct by checking the logs. or at least that your sound card was being detected correctly. Anyone know what setting needs changing to enable full logging like in mass effect? ideally the logs would say, detecting openal audio device, or using software sound.

 

If you have a creative card, try using alchemy, I gave it a shot, just to see, and it definatly does something to the game, it got very (overly) echoey .

 

also play with the settings under the alaudio heading, they may cure some of your issues.

 

I have also played alot of hours since using this fix, and i have had no crashes.

Don't see why software isn't in surround thugh, plenty of other games support this.

Share this post


Link to post
Share on other sites
  • 0

This works fine for me - full 3D sound, audio effects, etc. I have an X-Fi, though, so for those using on-board solutions it might be an issue.

Share this post


Link to post
Share on other sites
  • 0
This works fine for me - full 3D sound, audio effects, etc. I have an X-Fi, though, so for those using on-board solutions it might be an issue.

 

 

Me too. Thanks for sharing.

Share this post


Link to post
Share on other sites
  • 0

Although using Alchemy sounds better. I'm going to with the more like this fix is stereo X 2 mode someone mentioned before.

 

Anyways. It's not really a fix for all if people don't have a Creative sound card.

Share this post


Link to post
Share on other sites
  • 0
Although using Alchemy sounds better. I'm going to with the more like this fix is stereo X 2 mode someone mentioned before.

 

Anyways. It's not really a fix for all if people don't have a Creative sound card.

The only use ALchemy has is in restoring EAX and surround to games that use DirectSound3D, by converting the calls to OpenAL. Thus, ALchemy shouldn't have an effect in Alpha Protocol... unless the game somehow defaults to DirectSound3D if it doesn't think you have an OpenAL-compatible sound card, but I don't think I've seen a single Unreal Engine game do that. In fact, very few newer games use DirectSound3D at all - XAudio, OpenAL, Miles 3D, and FMOD are all far more common, and ALchemy isn't needed for any of those.

Edited by sea

Share this post


Link to post
Share on other sites
  • 0
Although using Alchemy sounds better. I'm going to with the more like this fix is stereo X 2 mode someone mentioned before.

 

Anyways. It's not really a fix for all if people don't have a Creative sound card.

The only use ALchemy has is in restoring EAX and surround to games that use DirectSound3D, by converting the calls to OpenAL. Thus, ALchemy shouldn't have an effect in Alpha Protocol... unless the game somehow defaults to DirectSound3D if it doesn't think you have an OpenAL-compatible sound card, but I don't think I've seen a single Unreal Engine game do that. In fact, very few newer games use DirectSound3D at all - XAudio, OpenAL, Miles 3D, and FMOD are all far more common, and ALchemy isn't needed for any of those.

 

i do not think i was ready for you to put words in quotation marks. i'll think about what you really want when you put your search in quotes and try to return something that makes sense.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...