Jump to content

ebon hawk/telos academy glitch

Recommended Posts

After I finish the secret academy and board the Ebon Hawk. Parts of the ship have invisible walls, and I cannot operate the galaxy map to leave the planet, has anyone else encountered this? Ive tried reinstalling the game and loading an earlier save, no luck .

Link to comment
Share on other sites

Im using the restored content mod, nothing else. Really weird problem, I haven't found any other mention of it.


It was an issue if you were close to nuetral the dialog would drop out prematuarly,the newest patch fixes it. http://www.deadlystream.com/downloads/TSLRCM_patch_vers 1.4a.rar:://http://www.deadlystream.com/downloa..._vers 1.4a.rar:

Edited by DarthStoney

Link to comment
Share on other sites

  • 3 years later...

Yes, I had the same problem just now.
For me the cause was, that I somehow missed T3M4 in the first mission. I just didn't have him, and the cutscene operates with him. So I got stuck in the middle of a cutscene. (and the cutscene map is not the same as the real one).


1st: quick workaround, didn't try, but might help. After cutscene, try to warp to the real ship. You still won't have T3M4, and maybe ever handmaiden, I'm not sure... risky one.

2nd: long workaround, I did that, and it seems to work correctly. (still a workaround...)

Select a savegame BEFORE the academy(underground base will do nicely). Warp to the first mission Administration level ("warp 101PER").
The quest there seems like it restarted, but it didn't, so don't worry. Go to the console, and colplete the T3M4 quest (

After the little guy explodes and you'll get control back, warp back to the underground base ("warp 232TEL" or 231TEL for the outside of it), and finish the quest there.
At least this is the plan. For me it didn't work, and I had to warp to the polar region at this point ("warp 261TEL"), because few of my squadmates were inactive for some reason, and I couldn't start the ship.
Either way, it worked in the end.

Notes: enabling the consolce is MUCH easier with english keyboard set. (you'll figure it out:  http://www.gamefaqs.com/pc/920601-star-wars-knights-of-the-old-republic-ii-the-sith/faqs/35636 )
You can use a savemage editor to make the "cheat enabled" marker disappear. This is.. well, not a cheat, so it would be unfair to treat it like one.

Hope I could be of assistance for someone :D
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...