Jump to content

Stuck at Telos (not cheat node)


Recommended Posts

Okay, so I just started playing TSL again and I recently ran into a new version of an old problem. When I came to the Telos academy, after talking to the handmaidens, the screen went black. I reloded the game, this time choosing the longer dialouge options...same result. So I patched the game and tried loading the dialogue fix. I can save the game and, when reloading it, Atton is standing right beside me, Atris is on the walkway to her chambers, Bao-Dur has dissappeared, Kreia and T3 are in their cells, and I can't board the Ebon Hawk or talk to anybody (including Atton, no "cheat node" or anything like it).

If anyone can help me on this, it would be greatly appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...