Jump to content

Character creation crash


Recommended Posts

I have a brand new system, just built it over the past month or so.

 

I just finished installing KOTOR II today. I've tried to start a new game a half-dozen times, but it keeps crashing before I can even finish creating a character.

 

System Info:

Asus P5E mainboard

Intel Core 2 Quad Q9450 @ 2.6 GHz

4 GB RAM (yes, I know this is more than the 3 GB "limit" for 32-bit XP, and no I haven't run the "fix" for this yet)

2 ATI Radeon 3870 cards (512 MB) (Sapphire), connected via Crossfire cables (this is the only device that KOTOR II gives a yellow flag for on system scan, recommends ATI 9200 or better, but 3870 is clearly a more advanced card than 9200...)

Windows XP Pro (32 bit), fully updated with all MS service packs, updates, etc.

KOTOR II 1.0b (had to download and install this manually as the updater couldn't seem to find the patch file)

I'm also using a wireless keyboard & mouse (Logitech MX 5000) which connects over bluetooth via Logitech SetPoint driver/software

 

Crash Info:

- happens at seemingly random times during initial stages of character creation (usually while setting custom stats)

- full system crash, I don't even get an error window message, nor do I get a Windows system error on reboot telling me the system recovered from a serious error. The whole machine just reboots.

- I've tried adjusting video, sound and movie (never even get to the first movie) settings, all the way to lowest settings, still get the same system crash

 

That's all I got folks, any ideas?

Link to comment
Share on other sites

Try running it on only one core and with only one graphics card.

Other than building another system or swapping out my CPU and removing a graphics card, how would I do this? Is there a way to force an app to run using only one core or only one card (a switch or something)? I could disable one of the cards in device manager, but how to deal with the cpu cores?

Link to comment
Share on other sites

I could disable one of the cards in device manager, but how to deal with the cpu cores?

 

You can disable one of the cores via the Task Manager -and you can tell it to only target the kotor2.exe- and one of your cards via the graphics control panel. I do not know about ATI cards, but Nvidia makes it fairly easy to disable SLI for only one application while letting the rest run normally. :p

 

 

Try running it on only one core and with only one graphics card.

There must be folks out there running this came on core 2 duo processors with dual cards...

 

And they normally have a massive amount of bugs if they do not do what I suggested. :)

"Geez. It's like we lost some sort of bet and ended up saddled with a bunch of terrible new posters on this forum."

-Hurlshot

 

 

Link to comment
Share on other sites

I could disable one of the cards in device manager, but how to deal with the cpu cores?

 

You can disable one of the cores via the Task Manager -and you can tell it to only target the kotor2.exe- and one of your cards via the graphics control panel. I do not know about ATI cards, but Nvidia makes it fairly easy to disable SLI for only one application while letting the rest run normally. :p

 

 

Try running it on only one core and with only one graphics card.

There must be folks out there running this came on core 2 duo processors with dual cards...

 

And they normally have a massive amount of bugs if they do not do what I suggested. :)

 

Thank you for the suggestions.

 

I have set swkotor2.exe to run with affinity restricted to only one processor core (core 0), and verified that it is running as such.

 

I have also disabled crossfire, which I understand is ATI's approach for running the game with just one gpu.

 

I can now get a character created, and play for 5-10 minutes, but then, inevitably, I get another system crash. Same type of crash. No error message, nothing. Just a reboot.

 

Any further recommendations?

Link to comment
Share on other sites

Try rolling back to the original game, as the patch might cause issues on some PCs. Also, try using an older graphics driver if you can - that might help.

I tried rolling back to 1.0 instead of 1.0b. In fact, for the second stage (single core affinity and single card), I had reinstalled the game and was working from 1.0.

 

As for older graphics driver, I'm not sure why that would help, and I don't want to mess up the rest of my system for other tasks/games, so that's not really an option.

Link to comment
Share on other sites

Try rolling back to the original game, as the patch might cause issues on some PCs. Also, try using an older graphics driver if you can - that might help.

I tried rolling back to 1.0 instead of 1.0b. In fact, for the second stage (single core affinity and single card), I had reinstalled the game and was working from 1.0.

 

As for older graphics driver, I'm not sure why that would help, and I don't want to mess up the rest of my system for other tasks/games, so that's not really an option.

 

Afraid this is still an ongoing problem.

 

I was able to get some level of stability from the game, for a time, by 1) disabling my 2nd graphics card in device manager and 2) running the game with affinity set to just one processor. This way I could usually play for a couple of hours, uninterrupted.

 

Or so I thought.

 

First of all, "uninterrupted" means the game wouldn't crash my entire system without warning or any error message (at least not until after a few hours of gameplay). But it would freeze on me at random intervals, usually for 3 to 5 seconds, and then resume as if nothing had happened. Initially I thought this was related to entries to new areas, etc. But, upon paying closer attention, not so. It does it randomly, even while walking around in the middle of an area with no enemies.

 

Would really like to fix this. I tried running the game completely dummed down on the graphics settings, still get the exact same freeze issue...

 

Secondly, in order to address the freeze/hang issue, I decided to install the new latest drivers from ATI for my cards (they just came out on 8/20). I had to completely uninstall my existing drivers, and the catalyst control panel, in order to install the new package.

 

As I mentioned, I was hoping this would resolve the freeze/hang issue.

 

Nope. Now I am back to square one, with the game completely crashing the entire system again, within the first few minutes of gameplay.

 

Again, tried running with graphics settings completely dummed down, no difference. Somehow it makes me wonder if the "uninterrupted" period was just a fluke, and whether the single core affinity and disabled 2nd graphics card have anything to do with the issue.

 

If anyone has any other ideas, or is able to play Kotor II on a multi-core system with ATI (preferrably 3870) graphics card, would sure appreciate your insight.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...