Jump to content

Help with mouse settings, please.


Recommended Posts

Quick question.

 

In KOTOR1 I always played with just one hand, running forward by pressing and holding both mousebuttons, this worked flawlessly, I could go entire gaming sessions using only my right hand, leaving my left hand resting on a more comfortable location.

 

KOTOR2 however, introduced the rather pointless feature of looking up and down. Now everytime I try to run the camera autocenters, causing a highly irritating jerk of the camera, which feels like someone is kicking on my monitor. The camera also tends to stall as I run, because I accidently drag my mouse up and down.

 

Could someone please tell me how to disable looking up and down? I really can

Link to comment
Share on other sites

Wow!! (w00t) It sure is true that you learn something new every day, i never even knew that you could both mouse buttons down and play the game!! AND rest it in a 'comfortable' position at the same time :p.

Link to comment
Share on other sites

Quick question.

 

In KOTOR1 I always played with just one hand, running forward by pressing and holding both mousebuttons, this worked flawlessly, I could go entire gaming sessions using only my right hand, leaving my left hand resting on a more comfortable location.

 

KOTOR2 however, introduced the rather pointless feature of looking up and down. Now everytime I try to run the camera autocenters, causing a highly irritating jerk of the camera, which feels like someone is kicking on my monitor. The camera also tends to stall as I run, because I accidently drag my mouse up and down.

 

Could someone please tell me how to disable looking up and down? I really can

OBSCVRVM PER OBSCVRIVS ET IGNOTVM PER IGNOTIVS

ingsoc.gif

OPVS ARTIFICEM PROBAT

Link to comment
Share on other sites

Now that you mention Swkotor2.ini;

 

Try looking in it for Mouse Look=

Try switching this one (from 1 to 0, or 0 to 1, matters to what is it with you)

 

Also try to add (beneath [Gameplay] the line Disable Ingame YAxis=1

(No guarantees it works though)

 

Just tried it, no luck. :wub: Even did Enable Ingame YAxis=0 just to be sure. There should be a command for it though, because when you press and hold mouse 1 you can

Link to comment
Share on other sites

Hans,

 

"pointless feature" to be able to have freelook while playing? I love it!

 

Wow, this shows how different we all are and how we prefer to play our games. This is one of the most welcome little control features that K2 introduced, something I was hoping they would implement!

 

The one thing that bothered me while playing the original K1 was that the camera angle was locked -- you couldn't look up and down while moving around in the game world. This is a typical console convention and has no place in PC games, where it's typical to give control over the camera to the gamer, since the mouse is such a superior control device for that.

 

There were scenes in K1 (Taris e.g.) where things were happening in the sky, and you wouldn't see it. Or interesting environments that you couldn't fully look at. The only way to do that was to go into 1st person mode (for which you had to stop moving and hit an extra button), which was awkward and non-intuitive.

 

I was really happy that they finally allowed proper control over the camera in K2.

 

But I understand your desire to play K2 one-handed, since that was an obvious alternative control system that the designers intended to support. However, as metadigital pointed out, games are typically played two-handed (even on consoles you need both hands to hold the controller). That's simply because today's games offer so much interactivity with the 3D environment and enough sophisticated gameplay that it's not practical anymore to control them with just one hand.

 

The only gaming genre I can remember that was simplistic enough for one-handed control were the classic point-&-click adventure games, and they were in 2D. For today's 3D games, the keyboard+mouse combination is just so much more efficient.

 

But I do feel your pain with the fact that the game carries over the stupid camera auto-center feature whenever you move with the 2 mouse-buttons. That is a console convention that I see with too many console ports for the PC, and I absolutely hate it. It has no place in a PC game!

 

To developers: We PC gamers (as opposed to console gamers) are always in control of the camera simply through the mouse, which is our main input device. It is second nature to us to look around freely. We don't need any "smart cams" and any auto-centering features that tell us where we should look. Don't take away camera control from the gamer in a PC game! That's a no-no.

 

I've played too many ports where I had to constantly wrestle with the camera, always fighting it, because it took away control from me. :blink:

 

So, I can understand your problem, Hans.

 

But I must insist, that I really like the freelook of the camera in K2. It's just unfortunate that you only get it when playing with the keyboard+mouse by using WASD keys for the movement -- then the camera won't auto-center. If you use the mouse-buttons for movement, then the game takes away control and auto-centers the camera.

 

Luckily, I play with keyboard+mouse, so this isn't an issue for me, and I enjoy the freedom to look around. But I can imagine how much the auto-center must annoy you when playing just with the mouse.

 

To make a long story short:

 

Obsidian should have really included an option to disable auto-centering for the camera -- as should ALL console-to-PC ports of 3D games, for that matter!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...