Jump to content

Kreia and Atton vanish on Telos

Recommended Posts



I've been playing this game for two or three days now, mostly bug free, which was cool considering all the stories i heard about the bug.


BUT now i've encountered what seems to be a possible game breaker (unless im really stupid and am missing something).


On Citadel, I've just managed to get the czerka protocol droid under my control. I use the droid to retreive the incriminating evidence in the mainframe and i return to the ithorians. When i return with the droid, i then regain control of my main character - but Kreia and Atton have totally and utterly vanished!


Obviously this is not good, as when i rush back to the Ithorians to save them from attack, i am overwhelmed and killed.


This is definitely a bug isn't it? Has anyone else experienced it? What can i do? I've tried reloading several different game files and redoing everything up until that point, but it happens each time.




Link to comment
Share on other sites

That happens to me everytime....i never thought about it as a bug. Just open the party selection screen and add kreia+atton from there. Works for me, how bout you??

Beyond this i dont know anything else....

Link to comment
Share on other sites

Err...just use the party selection screen and add the two "missing" party members to your party...this should solve the "greatest bug ever"  :rolleyes:


Edit: <SP beats me to it :)


You can also go back to the apartment where you are confined to on Telos. They are supposed to return there. Sometimes this has worked for me othere times it doesn't.

Link to comment
Share on other sites

Ah yes. Thank you. It turns out that I am in fact just stupid. Up until that point in the game I never had any reason to actually go in to the party selection menu, so i wasn't really aware of its functionality. When I saw my two party members missing, it just led to panic.


Cheers for pointing out the "solution" to my "bug" :)"

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...