Jump to content
  • 0

Stuck at black screen on launch - MacOS Monterey v12.5 M1


automata_m

Question

Due to no longer having access to an XBox, I've had to resort to playing Deadfire on my Mac laptop (lol I know), but after some time apart from the game I re-downloaded it on steam and haven't been able to get the game to "start"? The game loads and opens, but it is only a black screen. Doing research, I've tried to do the window mode method via CMD+F and yet either way, the game does not load up. No matter how long I wait, it's stuck at black screen. The application is up and running but it's literally just a blank screen. I do see a steam notification at the bottom right corner about the Steam community. 

I know Mac isn't optimal for this game, but I've managed to run this game on my laptop before, and initially have had to wait for the game bouncing on my dock for hours to fully load everything, but in the end it worked. But now that I've deleted the game and reinstalled it, it seems I'm back at square one, and the game won't start nor even go through the process where it bounces on the loading dock. Would prefer it to do that so at least I can try and wait for it to load up--instead of just a feedback-less black screen. Has there been any updated tips to get it working on Mac? 

Because I was able to get it to work before and had a good amount of playtime, it's not like I can get a refund on steam. And plus, I would love to get back to playing this game!

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...