Jump to content

Only English XCloud


Recommended Posts

same problem here.

I tried with my xbox account on a Xbox Series X, I deleted the save game, I also tried with my girlfriend's account (she never started the game, so I tried with a new save file).

Like you I've also tried with xCloud.

I'm going to try with the PC version, who knows if this works

 

Edit, PC version works in Italian so the issue is limited to the console version

Edited by Hard Init
update
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...