Jump to content
  • 0

Spell casting bug - spells fail to be cast without any reason




I have tried to search for other people discussing this bug and I replied in one other very old thread, but I thought I would be good to write an entirely new post about it now.

This bug has happened with my main character, who is a wizard and any other spell caster npc I have tried to play with.
These are Durance, Aloth and the druid guy (can't remember how to spell his name right now),. Possibly this has also happened with Eder when he attempted to use a 'clear cut' ability, but this was NOT totally clear in the case of Eder.
 But it is totally clear without any trace of doubt that it is happening with all the other guys mentioned above.

So - What is this bug about precisely?

My attempt to describe the bug:

Caster is commanded to cast a spell, for example slicken.
The caster (wizard in this case) goes into casting animation with the sounds of verbal utterance as well as the visual details of body movement and all as if he is going to cast the spell and everything looks right and well, then at some point (not always at the very end of the spell casting animation, but sometimes at the end also) he just seems to autocancel the spell so to speak, but he goes into recovery mode where the cool down bar displays so I have to wait for his next action as if he just finished the spell. But he did not finish the spell, nothing happened.
Not a single interrupt or spell of any kind interfered with the spell casting, there is not good reason what so ever why the spells suddenly decide to not happen, there is no other possibility than this being a bug. The spells are still available to be cast again without a loss of the number of spells I can cast per rest when this happens.

It does not happen every time I try to cast a spell.
Sometimes the spells are being cast successfully in the first attempt, sometimes in the second attempt, sometimes in the third attempt, sometimes I am lucky to have an entire fight without this bug, but most often not.
It seems very random, it can occur at the start of combat at the very first spell I try to cast or it can happen later, basically at any point.
I have tried all kinds of combinations to see if it was triggered when durance cast a buff while the wizard or druid was in casting animation, which would lead to them failing the spells, but I found out this had nothing to do with it. It really seems random from my perspective.


I had a lot of big fights with lots of spell usage in Crägholdt part of the expansion in the camp outside and the bug did not occur one single time (which makes the playing experience incredibly enjoyable). Interesting. Maybe this then shows that the bug only happens in the original poe and not the expansion? But I will need to test and verify that.
Another note of interest is that this bug did not occur at all in the early stages of gaming at lower levels and then suddenly it started to creep in at later stages. Then does it mean it has something to do with complex combinations of abilities, spells and items, which is why I only encounter the bug in at slightly higher level (can't remember precisely, but maybe from level 6-7 ish or something)?

Details that may be relevant:

I use windows 10, I bought the game on Steam, the complete edition. I have graphics on low to avoid lag (but this also happens when the graphic settings are on high).
I have tried turning AI off and on and it does not make a difference. I never play with AI for any of my party members normally.
I am new to this bug troubleshooting, please let me know if I need to list more details, thanks!

Final notes more personal notes about how this bug affects my playing experience:

I have played bg1 and bg2 a lot at nerdy levels and I became surprised how good this game actually is and I could even be tempted to rate this game higher than pretty much anything I have played before, it really is a masterpiece.
Or should I say potentially a masterpiece.
This bug kills the whole experience.
Imagine a game on hard, you plan, you calculate to the fraction of seconds, timing with all kinds of crazy spell and ability combinations in a really tough fight where you are slightly underleveled to make it harder and more fun! Then you just cannot have 2 or 3 spells in a row fail due to a bug, which totally makes the difference between winning or losing the fight. I like to play the combat at that level, where it is challenging, just what makes this incredibly fun for me personally and this bug makes it impossible to play the game for me then.

Thanks a lot if anyone cares to show up and help me out, if it is possible!

Good day

made a little edit to make something more precise to avoid misunderstanding.

Edited by Lopper
Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...