Jump to content

Exceedingly basic mod not working, someone take a look and advise please?

Recommended Posts

Hi guys,

Dipping my toes into modding and the simple test I am using (modding attributes and their caps) is not functioning.  The game appears to recognize it and load it, but I am not seeing my changes as manifested.  I don't see any issue w/ my json and I don't see any log file or anything to help me troubleshoot.  My json is tiny, so I'll post it here and ask that someone please look it over and advise me.  I have also tried breaking it up into two mods, but it didn't seem to matter.  I read something I didn't quite understand about modifying progression tables not working without including attributes that were not being modified, so I tried including the whole section.  It still didn't seem to work.  My folder structure is as follows: 


.\Pillars of Eternity II\PillarsOfEternityII_Data\override\







My  expanded-attribute-caps.gamebundle file looks like this:

  "GameDataObjects": [
      "$type": "Game.GameData.GlobalGameSettingsGameData, Assembly-CSharp",
      "DebugName": "GlobalGameSettings",
      "ID": "eddfc852-ccb9-4884-b901-e77e8ca31b48",
      "Components": [
          "$type": "Game.GameData.CharacterStatsSettingsComponent, Assembly-CSharp",
          "MaxAttributeScore": 666
      "$type": "Game.GameData.ProgressionTableManagerGameData, Assembly-CSharp",
      "DebugName": "ProgressionTableManager",
      "ID": "2be32291-5324-4410-9e26-a67d2d20b716",
      "Components": [
          "$type": "Game.GameData.ProgressionTableManagerComponent, Assembly-CSharp",
          "CharacterCreationAttributePoints": 15,
          "CharacterCreationMaxAttributeGulf": 666,
          "CharacterCreationAttributeMinimum": 3,
          "CharacterCreationAttributeMaximum": 666,
          "CharacterCreationBaseStat": 99


edit: The expected behavior is that I start w/ 99 points in each stat and am able to rebalance down to minimum of 3 or maximum of 666.  And that any stats that finish above 35 remain after reloading the game.

Any help would be much appreciated.  Thanks in advance!

Edited by FiveDoubleUZ
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...