Jump to content
  • 0
Oter2k

Steam Cloud save issues [Linux] (directories)

Question

 

Hello


I just reinstalled PoE2, after a hiatus, to complete the rest of the DLC, but I'm having issued with the save games. Specifically, getting them from the Steam Cloud and having the correct directories made by Steam.

Previously, there was a single save game directory

~/.local/share/PillarsOfEternityII/SavedGames/

Now ,this directory isn't created until I launch the game.

Now I have a total three (listed in the order they appear in my file manager):

~/.local/share/Pillars of Eternity II/SavedGames/	#1 - Cloud saves are downloaded here. PoE2 does not appear to read save data from here.
~/.local/share/PillarsOfEternityII/SavedGames/		#2 - Created by the game when launching. It loads save data from here, but no Cloud save data is downloaded here.
~/.local/share/PillarsofEternityII/SavedGames/		#3 - Cloud saves are downloaded here. PoE2 does not appear to read save data from here.

 

It seems Clouds aves are downloaded into the first and third directory:

~/.local/share/Pillars of Eternity II/SavedGames/
~/.local/share/PillarsofEternityII/SavedGames/


The second directory, which isn't created until the game has launched, does not contain any save files:

~/.local/share/PillarsOfEternityII/SavedGames/

 

There are no save files detected by the game (can't Load or Continue), which means that the game still only check the PillarsOfEternityII directory, ignoring the two others.
However, if I move save files to PillarsOfEternityII, the files appear in the running game. This is consistent with how the saving worked last time I played (May 2019).

And, of course, none of the new saves I make will crop to the two directories that seemingly sync with the Steam Cloud. I.e. I'm left with two directories that download files, and one from which I can load and save to, but it will not sync either way by itself. I'll have to manually try to force the new save files into the Steam Cloud, by deleting and moving files while the game runs so that Steam thinks the game synced them (it's a complete mess, tbh).

 

So, what's up with these multiple locations, that don't actually work, and is there a way to make the game, well, work correctly with regards to cloud saves? Without having to move around save files manually?
This all worked last May, so what's changed?

 

Edit #1: I've put a band-aid on the situation, by making a symlink to ~/.local/share/Pillars of Eternity II/SavedGames/ and put it down as ~/.local/share/PillarsOfEternityII/SavedGames/

This seems to have it work correctly, and sync accross devices. Since the latter directory doesn't actually sync, it should work fine. Though the moment (if) this is updated/patched/fixed, I suspect I'll be left with my saves being overwritten by a shortcut ._.

Edited by Oter2k
#1 Forgot to mention syncing of *new* saves ofc not working either. | #2 Short-term fix via symlink

Linux

¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...