Jump to content

Recommended Posts

Hi, I've encountered an issue with my game on PS4. During the past few days I haven't been able to progress through the story because of this issue I've encountered. Everytime I try to load into Stellar Bay I get a loading screen which never actually loads me into the area. I just get stuck in the loading screen. I have tried accessing Stellar Bay through Cascadia but that hasn't worked either. If there's any solutions to this problem please help me out. 


Link to comment
Share on other sites

I'm sorry for the issue you have run into. We have our development team looking into it and hope to have a fix for it shortly. In the meantime, to expedite your request, you can send an e-mail to our publisher, Private Division at support@privatedivision.com. This will get your issue into their queue and allow us to prioritize requests to ensure the fastest possible turn around time.

We apologize again and thank you for your patience while we work to resolve the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...