Jump to content

Stuck on Title screen


Recommended Posts

So i was able to play TOW last Thursday. Then today when I tried to play I got stuck on the loading screen right after the "Press any key" (I press any key, text disappear, and that's it). I tried to reinstall the game, update windows, unplug USB stuff (yes I read that on some site), tried to start the game without being connected to microsoft... that works but I have no saves, so I ahve to start over. 

Please help.

Link to comment
Share on other sites

I came across something similar, seems in the background it was asking for permission to access the net so as soon as i bought up the task manager i could see it was asking for permission on the task bar, pressed ok and it moved onto the next menu to play the game.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...