Jump to content

Can't progress on quest "Friendship's Due"


Recommended Posts

Unfortunately the first bug i ran into in the game prevents me from doing this quest. Whenever I talk to Felix to accept his companion quest, it accepts then immediately fails the quest, even while I'm still in dialogue with him. It shows up in the Botched section of my journal as well. I even tried doing the quest with a walkthrough, but I only got as far as finding Trusk I think his name was, but I couldn't talk to him. I thought maybe I had broken the quest with something I did earlier in my playthrough but looking at the walkthrough I can't see what I could have done. I tried reloading the save to before I accepted his quest, tried again to no avail. Reloaded it again and tried going somewhere else and accepting it, also didn't work. Every time I try it automatically fails the quest for some reason and I can't find anyone with a similar problem anywhere else. 

Link to comment
Share on other sites

Hey, EvaGhoul

I'm sorry for the quest issue you have run into. We have our development team looking into it and hope to have a fix for it shortly. In the meantime, to expedite your request, you can send an e-mail to our publisher, Private Division at support@privatedivision.com. This will get your issue into their queue and allow us to prioritize requests to ensure the fastest possible turn around time.

We apologize again and thank you for your patience while we work to resolve the issue.

Link to comment
Share on other sites

Thanks for replying. It’s okay, i finished the game on Saturday and when i started a new game it didn’t happen again. But I found out that for some reason it fails whenever you talk to Ellie about the events on Monarch. In order, what happened was:

1. Finished main Monarch quest by making peace between MSI & Iconoclasts

2. Landed on scyllia and accepted Felix’s quest (it didn’t immediately fail, at this point it was working fine)

3. Talked to Ellie about the events on Monarch. Towards the end of the conversation, i was notified that Felix’s quest had failed. 

I reloaded the save and tried it again and no matter what response I chose, at the end of that conversation with Ellie, Felix’s quest fails. And I can’t think of a reason why that might be. 

In the end i just didn’t talk to Ellie until i finished the quest. I hope this information somehow helps fix the issue. 

Link to comment
Share on other sites

Same here happened to me but despite of the failed quest, I was able to go Harlow's base and talked to the first NPC (Voelker) you meet after landing and then Harlow. I tested it. Here's what happened:

When talking to Trask, the dialogue does not trigger and you won't progress but you can take him down to get the ring. Afterwards, I returned to Harlow to finish the quest. I was able to talk to Felix on this ship and received the last items. However, there is no objective marker and the quest remained at the botched/failed section.

I should have tried your step about not talking to Ellie. I'll do this in my 2nd playthrough if there will be no patch/fix releasing at that time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...