Jump to content
  • 0
Sign in to follow this  
v0idwalker

POEII: Deadfire Linux Constant crashes.

Question

Posted (edited)

Hello there, 

I have no idea how to approach this as the game keeps dying on me and actually manages to freeze my whole PC.

(ryzen 1700x, asrock taichi x470, 32GB TridentZ underclocked, vega56 with current AMDGPU) 

I run steam on archlinux with stock kernel. 

The game has following symptoms: If i try to move into another area, there is the GUI but i cant see the characters, the only thing I see is the markers for moving to another area. If I load the game it loads correctly, but moving to another area has the same effect.  

The second, more severe problem is constant dying that actually takes my PC with it. The whole screen freezes, changes color to grey/brown and there is no reaction from the PC (does not react to numlock either) 

The only way I can play is using proton. But it has only 15 fps and no load on the GPU or CPU. Native, on the other hand, runs 75fps with vsync on, but kills my computer. 
Any ideas what could help? 

I have tried setting the path to native libSDL2.so with no success. 

thx! 

EDIT:
Additional notes. This behavior is specific to this hardware + software. The game runs just fine on my laptop (i7 4500U, nv750m, 8GB) with archlinux on it. (But the framertate is as bad as emulated on the main PC ~15-20 FPS) 
EDIT:

The problem during gameplay (the screen freezes but the GUI works and the game runs, just I can't see anything) is because of saving the game. After ANY save (auto, quick, normal) the screen becomes a static picture and I can interact with anything, but I don't see that.

Edited by v0idwalker

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi V0idwalker,

I haven't had the game running long enough to see if there are any crashes, but I had a similar problem with the 3d rendered game space failing (which I thought was due to scene changes, but it could well be due to saves) - I turned down the resolution and that doesn't happen any more (it isn't pretty, but it seems to work)

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

For your crashes, it might be worth trying the fix suggested here (and following the bug):

https://bugs.freedesktop.org/show_bug.cgi?id=109955

The following workaround has been reported to help (you may need to adjust the card0 to card1 if you have onboard graphics also...):

# echo manual > /sys/class/drm/card0/device/power_dpm_force_performance_level
# echo 7 > /sys/class/drm/card0/device/pp_dpm_sclk

this would be required to run on each boot...

 

 

Edited by Stew_rt

Share this post


Link to post
Share on other sites
  • 0

Hey, thank you for the response. 
In the end I finished the game just now via proton.

(20-30fps with no load on any of the components. Changing the performance level does not help, there seem to be a bottleneck somewhere else. I did try. It didn't change the framerate, just the amount of heat produced by the card.)

I will look into the bug, as it would seem that the game had issues because of AMDGPU driver. 

Thank you, again. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...