Jump to content
  • 0
Sign in to follow this  
AeonsLegend

Blow the man down -ringing bell still bugged

Question

So I'm playing this part yet again and again I run into the issue that the bell cannot be rung. I have done all prereqs. The questbook says I need to ring the bell. Lamond and his pals are gone and so is the ship. The bell doesn't work. This has been reported many times, but still has not been fixed. I really don't know what triggers the bug. Sometimes it works and sometimes it doesn't work. This time it will not work. I tried reloading, visiting other places, but the bell will just not trigger the scene where Benweth comes out. Ugh.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...