Jump to content
  • 0

[Bug?] Survivor's Tusk don't heal after reviving



I got the Boar's helmet (Survivor's Tusk) from the Crucible DLC, but when my character got downed in combat and resurrected next round, the healing didn't go through, even though the wound was removed as per description. Which is more, none of the rest of healing effects worked on me, as well - I tried Xoti's healing spells and my own character's Second Wind.


I don't know if it's a bug or something else that I'm missing. Here's my save file just in case - immediately after I finished a fight where the helmet didn't heal me:



Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...