Jump to content
  • 0
Lord Brunitius

Game freezing when loading areas

Question

During area transition the screen is still black after several minutes and you hear only the music. After a while the music stop and you're forced to close the game with crtl alt canc.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I also had this issue. I had to restore a previous save game and then was able to go through the area transition like normal. But the save games in which I was in that cell previously were "doomed" and stuck there permanently.

Share this post


Link to post
Share on other sites
  • 0

It happens to me all the time, it seems to be able to handle only 1 "in combat" type situation. I can do anything on the world map or boat, the first transition on board or on a map will work and all connected areas, but once i go _back_ to the world map the very next walking around area (including shipboard) will lock it.

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

I'm sorry you've been having freezing issues in Deadfire.  If any or all of you have output_log.txt files along with save games where this occurred or if you get them again in the future, please feel free to send them to us at support@obsidian.net along with your forum user name and a link to this thread as a reference.  If needed, you can find instructions on how to obtain all necessary files here.  All of these can help us figure out if these are individual issues or part of a more widespread issue that we need to resolve.

 

Thank you everyone, and sorry for the inconvenience these game freezes are causing.

Share this post


Link to post
Share on other sites
  • 0

1 thing is that after it crashes I need to go into the registry and change

 screemanager is fullscreen mode 

to 0, otherwise it won't load properly in the first place. That lets it load regions, but after it crashes it's back at 1 so I have to reset it before starting again.

 

Edit: I have the game in windowed mode by the way so it shouldn't ever be setting fullscreen as far as I know and autodetect is OFF so it should never change it to start with, let alone to something wrong.

Edited by Kinesia

Share this post


Link to post
Share on other sites
  • 0

I finally have a repeatable save I can send to support!

 

I can't get through Magran's Teeth, the text base intro happens, but when it moves past that it locks every time. I've done the other things that have worked before, but nothing this time.

 

Getting the stuff together to send now.

 

Edit: Oh! I just noticed Steam was running (because I'd reset at some point) and I vaguely remembered there were problems with that running, (I'm using the GOG version of Deadfire, try not to ever buy new stuff on Steam now), and after killing Steam and retrying the loading screen comes up (before it was just going to black screen with hand icon) and it actually works...

 

So steam is one of the blocking issues.

Edited by Kinesia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...