Jump to content
  • 0

Can't move, can't end turn





I'm playing Here Comes The Flood, the villain ate cards from a different location this turn (I think she tried an empty location and so couldn't eat any, but I'm not 100% on that), then I had Mer use her Healing Poultice she drew at the end of her turn, then when I tried to move Seoni the Move button is lit but doesn't respond.  Going to the map using the M key or the map button and double-clicking does nothing, the O key does nothing, the next phase/turn arrow is lit but does nothing, tried leaving to menu and returning, does nothing, tried exiting game entirely and returning, still nothing.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...