Jump to content
  • 0

Major Performance Issue: Frequent Periodic Freezing


Question

I recently started Pillars up again for the first time in a while and discovered it's basically impossible to play. I'm experiencing freezing every two or three seconds in-game (no FPS drop), and CPU usage is quite high even with no other processes. I find this very strange as the game was running perfectly before.


 


I had a similar problem with Overwatch but it fixed itself once I enabled full screen.  Tried fullscreen with Pillars but to no avail.


 


Is anyone else experiencing something similar? Please help!


System Specs:


Windows 10 Pro 64-bit Processor: Intel® Core i5-3570K CPU @ 3.40GHz (4 CPUs), ~3.8GHz 16 GB ram Radeon RX 480 Graphics 8 GB


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Having same problem as you. Game played fine two years ago and last year. Wanted to start back up again and the game randomly freezes anywhere from 1 to maybe 20 mins in game play if I'm lucky. Locks the computer up entirely. I have to do a hard reboot, Ctrl-alt-dlt does not work, nothing works except hard reboot. Really annoying as it makes the game completely unplayable. Sure as heck won't buy their sequel if does the same crap as this.

Link to post
Share on other sites
  • 0

A short update. I wondered why I did get instabile issues?

Well in my subjective case for some reason my computer did not like FRAPS enabled with Pillars of Eternity.

Well I did this two things not saing it will fix your issues, but it did solve mine:
A. Disable FRAPS and never run FRAPS with this game.
B. I am using free version of Zonealarm firewall and in that I set the Pillars of Eternity as trusted, but not supertrusted.


Third thing that could be your issue. I have laptop with Nvidia 1050 Ti 4GB DDR5. My particular graphic card is known to be gentle and not having overheating issues.

If the case would be overheating in your case check google what are ok temperatures then maybe better cooling system i.e hardware cooling system might solve your issue. Please note don't go shopping some expensive cooling system and then blame me if that
does not help! I am not sure what is causing your issues.

 

If you are curious about my hardware, what I am using:

This is my performance/price gaming laptop:
Acer Aspire VX5-591G 15.6" GAMING LAPTOP (black)
15.6 inch screen easy to carry into airplane even if you move to another country.
CPU: Intel Core i5-7300HQ
That is Kaby Lake newest of Intel consumer market CPUS.
This particular Kaby Lake is 4 cores and 3,5GHz in TURBO MODE.


Graphic card: Nvidia GTX 1050Ti, 4 GB DDR5

Source:
http://www.pcworld.c...ns.html?page=10
Nvidia GeForce GTX 1050 and GTX 1050 Ti review: The new budget gaming champions
www.pcworld.com
Nvidia's GeForce GTX 1050 and GTX 1050 Ti are the best graphics cards for budget gamers and people looking to upgrade a prebuilt "big box" PC.

"
Nvidia GeForce GTX 1050 and GTX 1050 Ti review: The new budget gaming champions
Bottom line

Nvidia truly knocked it out of the park with the GeForce GTX 1050 and GTX 1050 Ti. Not only are these graphics cards a worthy successor (and worthwhile upgrade) for the legendary GTX 750 Ti, Nvidia’s cards are notably cooler, notably more power-efficient, and notably more powerful than AMD’s Radeon RX 460. "

Memory: 8 GB DDR4 RAM

1 TB HDD
What no SSD? Does not affect gaming, but Windows boots/starts slower.

Operating system: Windows 10. I do have separately a 24 inch gaming monitor with 1 ms response time and Flicker-free , TUV Low Blue Light technology.

Edited by Terminator
Link to post
Share on other sites
  • 0

In addition if in theory it is your Windows you could try Windows system restore. Google how to do it for example google Windows system restore Windows 10. In case you don't have a restore point created it shows grey and nothing can be chosen then this possible troubleshoot is not possible for you.

Link to post
Share on other sites
  • 0

I don't know if i'm experiencing the same thing. The game stops and starts every 3 seconds or so. I've just about tried every setting, version and disabled all the GOG in game features. It does this even in the opening cinematic. I couldn't make it past the past character creation. Hope there's a fix to this. 

 

Specs:

 

Radeon Software Version - 17.5.2
Radeon Software Edition - Crimson ReLive
Graphics Chipset - Radeon RX 480 Graphics
Memory Size - 8192 MB
Memory Type - GDDR5
Core Clock - 1306 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 8 GB
CPU Type - Intel® Pentium® CPU G4600 @ 3.60GHz
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...