Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Controls Only Bind To Left Ctrl Bug

- - - - -

  • Please log in to reply
4 replies to this topic

#1
TeethMuncher

TeethMuncher

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:TeethMuncher

To clarify: When I try to bind a key, it always binds to left ctrl, no matter what key I press.

I've done a bit of research and discovered someone who posted the same issue back 2015:
https://forums.obsid...d-to-left-ctrl/

The solution put forth was "verify integrity of game cache". I've done this (didn't work), then reinstalled then tried again (again, no luck).

I am playing through Steam and my game version is version 3.05.1186, which seems to be the latest as of now 2/13/17. Can anyone help me?



#2
Xaratas

Xaratas

    (6) Magician

  • Members
  • 711 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

The easy part: All Keys which map to ascii

Decimal number from here http://www.asciitable.com/

is the value for the prefs file.

Which is in Linux here: ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity

 

The hotkeys start with ct_ and are base 64 encoded.

The decimal number is first, then followed by ":000|", multiple keys are possible.

 

The hard part: Finding the correct number for right ctrl



#3
TeethMuncher

TeethMuncher

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:TeethMuncher

The easy part: All Keys which map to ascii

Decimal number from here http://www.asciitable.com/

is the value for the prefs file.

Which is in Linux here: ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity

 

The hotkeys start with ct_ and are base 64 encoded.

The decimal number is first, then followed by ":000|", multiple keys are possible.

 

The hard part: Finding the correct number for right ctrl

 

Thank you for responding.

 

I'll be blunt: I don't quite understand your response and I'm unsure how to proceed.

 

Are you suggesting that there are files that need to be replaced/updated?

 

I'm using Windows 8, btw.



#4
Xaratas

Xaratas

    (6) Magician

  • Members
  • 711 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Sorry if i started to steep.

There is a file named "prefs" which saves the asigned hotkeys, and because you said the game itself don't let you bind the right ctrl you would have to edit this file.

Make a search for unity3d in %AppData%, i would expect the file under windows there.

 

To make things not so easy the keycodes are encoded in base64 in the file.

<pref name="ct_SELECT_ALL" type="string">ODowMDB8</pref>

If you decode "ODowMDB8" you get "8:000|".

The 8 is the ascii value of Backspace. The rest is some kind of padding.

 

As I wrote, i have not worked out what are the numbers of the modifier keys, and the unity documentation does not contain that info too.



#5
TeethMuncher

TeethMuncher

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:TeethMuncher

Sorry I didn't reply sooner.

 

I think you misunderstand my issue. When I try to bind an action to a key, for instance let's say I wanted to bind "Select All" to the "enter" key, it always binds it to "Left Ctrl" instead. This happens no matter what action I try to rebind, or key I press to bind it to.

 

Now I've taken your advice and found "pref" folder by using the Windows Registry Editor. Unfortunately, I've become stuck one again. I could convert decodes so that actions are properly bound according to my preference, but that wouldn't fix my issues.

 

Thank you for your help so far though.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users