Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Sins of the Saviors / Thassilonian Sins Scenario Can Not Complete


  • Please log in to reply
26 replies to this topic

#21
Lord Phobos

Lord Phobos

    (0) Nub

  • Initiates
  • 3 posts

And having to forfeit the game at the end of that combat caused the permadeath of my well experienced Sajan, now... -_-

There's a way to have him back?



#22
Mondkuss

Mondkuss

    (1) Prestidigitator

  • Members
  • 8 posts

It seems this problem is NOT scenario specific: I encountered the progression bug in 5-1 Attack on Sandpoint

I played with Ezren, Valeros and Merisiel.

Three locations were permanently closed, one temporarily. Ezren encountered The Scribbler at the Thassilonian Dungeon and defeated him for the first time (which means he is NOT defeated (Villain's special power). Ezren used his power to draw a card after playing a spell and afterward there was the blue arrow. However clicking on it didn't do anything, so I was stuck!  :(

Going to the vault or main menu didn's solve the problem...

 

MyPFID: C22CC0864AE53A9E

 

  • What device type are you on? iPad pro
  • What version of the OS are you running? iOS 10.1.1, etc.

Login Issues

  • When you launch the game, does the welcome popup appear for Game Center/ Google Play Games? Yes
  • On the main screen, what is the text displayed in the blue box at the top? Nickname and #

Gameplay

  • Is pass & play on?  Is permadeath on?  No and no
  • Tutorial, Story Mode, or Quest Mode? (If not quest mode, did you recently enter it?) Story mode
  • Characters in Party  Ezren, Valeros and Merisiel
  • Location of each character  Ezren at Thassilonian Dungeon, others ?
  • Turn Order Ezrens turn
  • Scenario & Scenario Difficulty.  If on non-normal difficulties, which wildcard powers are in play? Heroic difficulty, Wildcard: bury card when aquiring item etc.
  • What card was encountered when the issue occurred? (Or check, or card just played, etc) Combat check against The Scribbler
  • Did the issue occur on the first explore or a subsequent explore? First Explore, combat check successful


#23
Srvannor

Srvannor

    (2) Evoker

  • Members
  • 64 posts
Also cannot progress in 5-4. All villains dead, all areas closed. Just a flashing blue arrow at right of screen that does nothing when clicked. Clicked around all the game menus and turned things on/off. Nothing works. Frustrating. Don't you guys test this stuff before implementing? C'mon.

#24
aznxknight

aznxknight

    (3) Conjurer

  • Members
  • 113 posts

I want to also note that after defeating a villain by cornering him you will be able to move all characters at current location that has just been closed. At this point DO NOT, i repeat, DO NOT go to any menu trips, vault trips, etc. or you will end up soft-locking the game and forced to forfeit. The "confirm actions" text and also the non-functional blue arrow button pops up but as stated the button does nothing, soft-locking the game.

 

I did encounter another bug where i defeated all 3 villains by cornering them but the game did not end. The fix was that I just had to close all locations and the game ended in a victory. Unsure why that happened because in another attempt i was able to end the game after the 3rd villain is defeated.

 

All have been 6 party games if that mattered.


Edited by aznxknight, 21 November 2016 - 09:05 AM.


#25
elcoderdude

elcoderdude

    (3) Conjurer

  • Members
  • 128 posts

I think what happens specifically in this scenario is that it wants your characters to move away from the location where you beat the final villain. Whenever I beat this scenario, I have to double-tap on other locations to move my characters away (from an impending explosion?) before it will give me the "Scenario Completed" screen. It's a bit weird.


This worked for me.

Solo Lini

#26
Coremus2k

Coremus2k

    (0) Nub

  • Initiates
  • 2 posts
Hello,

This quest is uncompletable as every time you kill the last villain the game forces you to move to another location and then just hangs leaving you with no option but to forfeit. I have tried completing it several times in different ways, permanent and temp closing, and always the same thing happens.

This is particularly annoying as I have paid full price for the Rise of the Runelords bundle.

Two questions:

1. Does anyone have a workaround?
2. Can the developers indicate when this will be fixed?

Thanks

#27
Dezbend

Dezbend

    (0) Nub

  • Initiates
  • 1 posts
General:
Android 6.0.1 Galaxy s6 active
6818212E403367D4

Gameplay:
Story mode no pass and play nor permade athletes.
Seoni, merisiel, Kyra, harsh.

I have beaten Thassilonian Sins twice but both times the game does not move forward. I am stuck on someone's turn with nothing to do.

I have to forfeit the game to get out of the scenario and then I do not get credit for beating it.

PS writing in to support is way harder than it should be :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users