Jump to content
  • 0

Games open at 0x0x0hz resolution - GTX 960 + Pillars of Eternity


DKrutzke

Question

Hello,

I've looked everywhere for a solution to this, but haven't been able to find one. 

My games are setup to start on my primary monitor. I recently tried running Pillars of Eternity from Steam, which i just downloaded. On startup, my mouse jumps to the top left of my primary monitor and stays there. There is no video that shows and i can still see my desktop, but the title music plays. It is as if the game does start, but the window is basically nonexistent. My mouse responds when i move it, but all does is flickers and stays in the top left of the screen. I have tried it on my other monitor and changed to just one monitor with the same effect.

 

My GeForce Experience has the "Current Settings" of the game locked at 1024x768 when my primary monitor is at 1920x1080. When i hit "Optimize," 9/10 times, nothing happens. When it does give me the green light and says "Optimized", it opens at 1920x1080, then gives me the error "couldn't switch to requested monitor resolution" and behaves the same with the pointer in the top left. I get a dialog box that says it reverted to a 0x0x0hz config, which makes sense considering whats happening with my mouse. I also recently installed No Man Sky and it ran fine. I have also checked my other games with the current settings and they seemed OK. 

 

So I'm wondering why the game would default to a different resolution, not let me change it, then not work at all. I've tried doing a clean wipe of my drivers, used the alt+win key to change the window mode, checked any settings in the NVIDIA control panel that would be affecting the program, validated the files from Steam to see if any of the files were corrupted, deleted the UNCL font, and changed the compatibility of the program to run at 640x480, but haven't found anything that works.

 

My set up right now is:

Windows 7 64x bit

Intel® Core i7-3770K CPU @ 3.50GHz

GeForce GTX 960

 

I have attached my output_log.txt file as well. Any suggestions or comments i can get would be greatly appreciated and i would give more info if someone needs it. 

Thanks in advance. I really want to play this game =B

output_log.txt

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The force to 640x480 does not help, remove the compatibility mode settings.

Can you delete all „Geforce experience“ profiles for PoE and run the exe file directly (not via steam)?

 

Second, disconnect in the windows settings the second monitor, no need to disconnect the cable. Then try again.

Link to comment
Share on other sites

  • 0

Thanks Xaratas,

I disabled the 640x480 compatibility function after it didnt work and also tried to completely uninstall the GeForce Experience program to no avail. I am not sure how to disable the PoE profile, however, so I dont know if that would work better. Also, when i disabled my second monitor, I did so in windows and didnt unplug it; that didnt work either.

 

Thanks again

Link to comment
Share on other sites

  • 0

Still with the second monitor disabled, if you set the main monitor resolution to 1024x768 the game starts?

Since that is the resolution geforce experience is trying to enforce, let's see what happens if you use it.
 

I've come to burn your kingdom down

Link to comment
Share on other sites

  • 0

I suspect this will not work if something (like the nvidia profiles) is messing up the game launch, but I'd try anyways to set the game to windowed mode and manually change the resolution settings.

 

Before you start create a system restore point, as the game settings are in the registry.

Windowed mode

You tried this before, but maybe uninstalling the drivers changed something.

Launch the game, when you hear the second music theme alt+enter.
Likely nothing will happen, as alt+enter switches between full screen and borderless mode at the current resolution - and the game seems to be having issues with the resolution.
Close with Alt+F4.

Pillars registry settings

Open the output log, find the resolution index associated to 1024x768, write down that number.

Open the registry (run: regedit).

Search "Pillars" until you find the game settings section (should be in HKEY_CURRENT_USER\Software\Obsidian Entertainment\Pillars of Eternity).
Change the following values in the register:

_currentDisplayMode... = 2
_currentResolutionIndex... = whatever 1024x768 was in your output log
FULLSCREEN_h... = 0
Resolution_... = 1024&768&60
Screenmanager Is Fullscreen mode_... = 0
Screenmanager Resolution Height_... = 300
Screenmanager Resolution Width_...= 400

Edited by Suen

I've come to burn your kingdom down

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...