Jump to content
  • 0

Stuck when burying an item


zeroth_hour

Question

So I decided to fiddle around with the Legendary and grind Local Heroes with Seoni and Kyra

 

But I got stuck and I can't go any further.

 

Here's a screenshot: http://imgur.com/PveiFXc

 

I buried the item, then I couldn't go any further.  Decided to exit and reload, still no luck :(

 

EDIT: I managed to get through by randomly clicking into a location (I think????)  It was really weird

Edited by zeroth_hour

You can use the 'Mark Solved' button beneath a post that answers your topic or confirms it's not a bug.


The time that devs don't have to spend on the forum is a time they can spend on fixing the game.


(Thanks to Longshot11)

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...