Jump to content
  • 0

LOW FPS-Bad performance


robwarrior

Question

Hi guys my name is Robert and I need technical support plz.  The problem I am having is I am getting painfully low fps (around 15) in game.

 

Here are my computer specs.

 

graphics card: powercolor Radeon boost state hd 7950

mobo: ASUS m5a97 r2.0

windows 7 64 bit

ram 8gh

aMD FX 8320 EIGHT CORE Cpu

 

I have tried different drivers atm I am using the drviers from here

http://support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064

 

I wanted to use the drivers from http://www.powercolor.com/US/products_features.asp?id=435#Specification  here but it wont dl them.

 

The only thing I can think of is that I have the wrong driver or my Bios needs updating can u guys plz help me I would like to enjoy this game.

 

I have tried different drivers, updating my chipset, updating my sound drivers, updating my lan, and updating my usb.

 

Plz help me thankyou

post-151814-0-34055500-1428700946_thumb.png

DxDiag.txt

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...