Jump to content
  • 0

Patch won't download


Laggy

Question

Title says it all. Steam downloads the latest patch to about 90 megs, then stops. When I hit resume, it starts at zero again, then the cycle continues. I tried resetting the computer, choosing a different download server, validating Steam files, nothing worked. Also, Steam will not let me start the game until the patch downloads.

I tried making this thread in the Steam forums, but no one was able to help me.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...