Jump to content
  • Sign Up
  • 0
Morgawr

Cannot turn off fullscreen on linux

Question

So... Since the game auto-pauses when I alt+tab out of it (which I hate because I want to do other stuff while I send my chars to backtrack on the maps) I want to run the game in windowed mode (Borderless fullscreen). I tried turning it off in the game's option (the fullscreen checkbox) and every time I save the options, the game stays fullscreen and when I go back in the menu it's still checked again. Even when I change the resolution the screen flickers but it stays 1920x1080 (my resolution) anyway.

 

I also tried to change the config file manually but when I boot it up it's still checked.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

So... Since the game auto-pauses when I alt+tab out of it (which I hate because I want to do other stuff while I send my chars to backtrack on the maps) I want to run the game in windowed mode (Borderless fullscreen). I tried turning it off in the game's option (the fullscreen checkbox) and every time I save the options, the game stays fullscreen and when I go back in the menu it's still checked again. Even when I change the resolution the screen flickers but it stays 1920x1080 (my resolution) anyway.

 

I also tried to change the config file manually but when I boot it up it's still checked.

Same issue. It's also game-breaking if you have a dual monitor setup, as apparently windowed is the only way it works.

Share this post


Link to post
Share on other sites
  • 0

I am also having this issue on Mac - exactly the same as described. I uncheck it leave the settings menu, nothing changes and re-entering settings shows the box checked for full-screen again. If I've made any additional settings changes they are all exactly as I set them - the only one that doesn't save is the full screen option.

Share this post


Link to post
Share on other sites
  • 0

I had that too. This is how i fixed it. Make certain that the chosen resolution fits the chosen window size, eg. I have a 1920x1200 monitor and in full screen mode the game would show that resolution. After switching to window mode I had to set the resolution to less than that (1600 something) for it to switch successfully.

Share this post


Link to post
Share on other sites
  • 0

I had that too. This is how i fixed it. Make certain that the chosen resolution fits the chosen window size, eg. I have a 1920x1200 monitor and in full screen mode the game would show that resolution. After switching to window mode I had to set the resolution to less than that (1600 something) for it to switch successfully.

This does not work for me. The bug persists and it's VERY annoying.

Share this post


Link to post
Share on other sites
  • 0

 

I had that too. This is how i fixed it. Make certain that the chosen resolution fits the chosen window size, eg. I have a 1920x1200 monitor and in full screen mode the game would show that resolution. After switching to window mode I had to set the resolution to less than that (1600 something) for it to switch successfully.

This does not work for me. The bug persists and it's VERY annoying.

 

 

This does not work for me either - specifically in my case there was only one monitor resolution available - the native resolution of my monitor so there was nothing to change it to that could be smaller.

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

I've stumbled upon this issue too. What worked for me:

1) find PoE config file under: ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs

2) do a backup

3) find and modify to following lines accordingly inside that file:

<pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
<pref name="Screenmanager Resolution Height" type="int">900</pref>
<pref name="Screenmanager Resolution Width" type="int">1600</pref>
<pref name="_currentDisplayMode" type="int">3</pref>
 

I'm using the latest version from GOG: 1.0.3.0530

 

If you need my config file (although I've started from an empty one) just PM me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...