Jump to content

Linux command line & save options


Recommended Posts

I'm trying to launch the game on one monitor with the proper resolution, right now it is picking up combined resolutions and opening in a way where I can't see the whole screen. Mouse pointer and area/widget getting the click is also off by ... a lot!

 

I've tried to pass parameters (from quick strings/grep of the binary) --screen-witdh --screen-height , windowed etc. These echo on the title screen but don't change anything else.

 

I've managed to click the 'full screen' check box to uncheck it, figuring this will be easily sorted in windowed mode so I can move it around.

 

Nothing changes and that setting doesn't actually stick (it is always checked if I go back into menu, same for all settings actually).

 

Strace doesn't show any settings file being opened when starting/saving/exiting the game (only shows mono junk).

 

Help?

Link to comment
Share on other sites

Yeah, I'm seeing the same thing. I even managed to locate the Resolution dropdown on the Graphics settings by blind mouse-feel, but I guess I wasn't clicking in quite the right spot because I wasn't quite able to get it to activate.

 

I ended up flipping my displays into mirrored mode for a second, starting up the game, setting everything up and it was all good. It managed to remember windowed mode and a sane resolution, even after restarting the game. I tried to look for a config file in the local data (because seemingly everything else is in a file), but either I didn't look hard enough or it doesn't exist.

 

Pretty much every Unity game I've played on Linux recently has done this and I'm starting to get a little tired of it. But at least I've learned to work around it for now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...