Jump to content
  • 0

Xbox360 unplanned parenthood glitch



Ive read over other posts concerning this specific problem I've encountered and cant find any confirmed solutions or work arounds. Some of us are unable to progress through the unplanned parenthood mini game due to an error experienced during the third procedure done to Randy. The glitch omits the displayed prompts to move the suction tube left or right, and the controller becomes unresponsive once the tube is moved to the left (the only command the game responds to)-resulting in the cut scene where Randy's testicle is sucked up the tube and your character getting shot to death. Of note, if no imputs are made after pressing "A" to start the last procedure, after a short period of time the suction-death cut scene will play, with delayed audio.

This glitch completely arrests progress through the game, rendering it unplayable past this point. I'd like to see of anyone who has experienced these specific problems has found a solution. Please understand, I've seen a friend pass this part on his console, with no problems, since the prompts show up for him in his game. Also, starting from a previous save point does not help- I've tried it twice now with the same result. Uninstalling and reinstalling the game or day one patch from the HD does not help either.



AND why has Obsidian been quiet on this particular issue?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

  • Create New...