Jump to content

More problems with vista


Recommended Posts

Hello,

I have had this game for a while now but am just now getting around to playing it a 2nd time. However, now I have a new computer that runs with windows vista and have had problems getting the game to run. I have looked a multiple forums about getting the game to run and tried replacing my .exe file, and replacing my mss.dll file. none of these fixes work. I think this is because my problem is not there.

 

When I start the game the first time it runs the system scan, i pass with flying colors everywhere except for display drivers. It says I fail them. That is far from the truth. The problem is that my display drivers are newer then the game and the patch for the game so it does not have any idea what they are.

 

Here are some facts about my system, if anyone could help I would be greatly appreciated.

 

System Information

------------------

Time of this report: 8/11/2009, 00:58:24

Machine name: ADAM-PC

Operating System: Windows Vista

swinfo.txt

Link to comment
Share on other sites

I am also having issues with Vista and this game.

 

Specs:

i7 920

6gb ram

GTX 280

Realtek ALC888 sound card with latest drivers

Vista 64 SP1

 

I tried the work around listed with swapping out the mss32.dll (took me a while to find one to download as the link is dead) and it still crashed during load.

I then I replaced the mss32.dll with one from my NWN folder (yeah its old) and the game will now run, but with no sound. (NWN has sound)

I also noticed that the wav files won't play in windows media player, it gives a codec not found error. (I have the latest version)

 

Any ideas?

Link to comment
Share on other sites

KotOR II will tend to be quite fiesty on Vista, I think there is a thread called "How to KotOR II on Vista", that thread may be more help. It is possible to get KotOR II to work on Vista, that I know.

 

I tried all of the fixes listed and still got no sound or cut scene love... then I found this little gem of a download:

 

http://knightsoftheoldrepublic.filefront.c...sta_Fix%3B85439

 

Slapped it in and it worked like a charm.

The only other issue I had was when I went to the city from the space port on Onderon (sp?) the game crashed unless I put all of the gfx settings to lowest. *shrugs* Once I got in the city everything worked fine on max settings again. I have had some issues like this in the past with NWN, and it was always a texture or shadow image.

 

Can a mod add the link above to the fixes page?

Link to comment
Share on other sites

Uninstall Vista and install XP. Barring that, buy an XBox or try running it in compatibility mode.

In 7th grade, I teach the students how Chuck Norris took down the Roman Empire, so it is good that you are starting early on this curriculum.

 

R.I.P. KOTOR 2003-2008 KILLED BY THOSE GREEDY MONEY-HOARDING ************* AND THEIR *****-*** MMOS

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...