Jump to content

[Bug] The Doom That Came to Roseway - Quest Completes before Talking to Anton


Recommended Posts

I haven't found this issue with online so I thought I'd post here.  I've already posted on Reddit but so far no one else has had this issue.

Issue: Unable to give Anton the research data.  Quest is marked as complete before talking to him

What I did:

  • Convinced Cassandra to hand over the research
  • Negotiated peaceful conclusion for guards and outlaws

What happens: As soon as I enter Roseway, the quest completes even though I haven't spoken to Anton yet. When I enter the Comm lab, he's arguing with Porter about letting the outlaws go. Speaking with Anton only allows me to ask questions about his background and nothing related to the quest.

Notes: The data is in my inventory

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...

Same issue here. You get the XP for finishing the quest, but not the faction reputation. I tried reloading, leaving Roseway, restarting the game, but the issue persists. Not sure what would happen if you also sold the research to Gladys.

 

I convinced Cassandra to hand over the research, sent her to the Iconoclasts and got the guards to leave peacefully. 8/12 rapts were killed but the matriarch survived. Playing on PC.

Link to comment
Share on other sites

  • 2 weeks later...

Got just the same issue. Version 1.5.1.712, both DLCs installed. Playing on Supernova.

Did the following:

  • After completing "By His Bootstraps" quest told Anton that his dream of Byzantium is meaningless (lines with Persuade check)
  • Negotiated peaceful conclusion for guards and outlaws
  • Killed 3/12 raptidons, sedated the rest of them
  • Convinced Cassandra to hand over the research

Guess, I should replay a decent part of the Roseway story and resolve the quest in a different way, which will not fit my current character. It's a shame.

Although, did all the players here encountered the bug after killing (at least several) raptidons in the lab? Maybe with 0/12 the quest resolves correctly?

UPD: Tried to proceed with the quest a little different, but with the same outcome (negotiated peace, Cassandra handed over the research). Killed 0/12 raptidons this time, tried both options with the security keycard to open the fence. Nothing changed, the issue still persists. For now I decided to postpone the walkthrough until the issue will be resolved. Captain Janeway don't like other outcomes in a least. :) I also sent a ticket to Private Division. I hope they'll respond, 'cause support on this forum seems dead to me.

UPD2: Got an answer from the Private Division support team. They confirmed the bug after receiving my save data and forwarded the issue to the QA team. Lets us hope for resolving it in near future. :)

Edited by logarifmik
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...