Jump to content

Grounded Not Saving Anymore

Recommended Posts

On March 16th I saved and logged off grounded at 12:02PM. I logged back on around 2 and started playing. A few hours later I saved and logged off for the day. The next day when I logged on, I only had a saved game from 12:02. Nothing I did after that saved. I did a hard reset on the Xbox and looked again. Still the 12:02 save. I did a few tests over the next couple days. I would play for 15 minutes and then save/logoff. When I would get back in, the save is gone, still just the 12:02. I even tried deleting old saves to see if there was a limit on number of saves. Still not saving. Any help would be appreciated. I love the game and want to keep playing but can’t if progress won’t be saved.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...