Jump to content

Recommended Posts

I bought The Outer Worlds through the Epic Games store and was able to play for about an hour before it crashed. When I try to reload the game I'm meet with a black screen for a few seconds before it defaults back to the Epic Games Launcher home page. I've tried deleting and reinstalling both The Outer Worlds and the Epic Games Launcher but neither worked. I have a few other games through Epic Games but the Outer Worlds is the only one to have this problem. Any help is greatly appreciated. 

Link to comment
Share on other sites

Hey SuperNova1,

I'm sorry for the crash you have run into. We have our development team looking into it and hope to have a fix for it shortly. In the meantime, to expedite your request, you can send an e-mail to our publisher, Private Division at support@privatedivision.com. This will get your issue into their queue and allow us to prioritize requests to ensure the fastest possible turn around time.

We apologize again and thank you for your patience while we work to resolve the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...