Jump to content

Recommended Posts

Just wanted to post this in case it helps anyone else.  I was having crashes when trying to start this game.  It would freeze and crash right after the character creation, right when you are in the pod going down to the first planet.  Happened every single time.  The fix for me was to turn off the overclock on my gpu.  I use Precision 1X and I have a profile saved with my OC, so I created another one with the default clocks.  This immediately fixed my issue and i was able to actually start the game.

Link to comment
Share on other sites

Hey, jef152

I'm glad you were able to fix your issue! If you run into this, or any other issue in the future, you can send an e-mail to our publisher, Private Division at support@privatedivision.com. This will get your issue into their queue and allow us to prioritize requests to ensure the fastest possible turn around time.

Thank you for playing!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...