Jump to content

Devils peak station broken


Recommended Posts

Hey there, I keep going to devils station after getting nyoka and as soon as I go through the door to the broker there, the game crashes from the loading screen. I have a Ryzen 7 3700x and a msi 2060 super. Updated drivers, current windows update, has not worked. Even tried an earlier save and same problem. Anyone else have this problem or know a fix? Thanks in advance.

Link to comment
Share on other sites

Hey, Carnagelot

I'm sorry for the crash you have run into. We have our development team looking into it and hope to have a fix for it shortly. In the meantime, to expedite your request, you can send an e-mail to our publisher, Private Division at support@privatedivision.com. This will get your issue into their queue and allow us to prioritize requests to ensure the fastest possible turn around time.

We apologize again and thank you for your patience while we work to resolve the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...