Jump to content

Game Crash on start - Gamepass version


Recommended Posts

That indicates a problem loading a file into memory, and Windows is closing to prevent damage.

Are you using the Store or the Epic version of the game? I'm curious if there's any more detail in the Event Viewer... to check, open Start, type in "Event Viewer" and press Yes if User Activation Control asks you to. Once the next window loads, expand the "Windows Logs" entry in the left frame, and select "Application". On the right hand side, there will be a "Filter current log" option. Click that, then check the Critical, Error, and Warning checkboxes, then press okay.  You will see entries in the middle pane - are there any which coincide with the time of the crash? (When you select one, its details appear on the lower half of the middle pane - the text in the "General" tab is what you'll want to look for).

Also, I feel like verifying the integrity of the system might be an idea. Press Windows key + X, click Command Prompt (Administrator) or PowerShell (Administrator) (whichever shows up), and run the below command. Reboot, then try again.

sfc /scannow

Could also just be a bad install - verify the files if Epic, reinstall if Store.

Let us know how you go.

Link to comment
Share on other sites

Hello.  This is the version from  Xbox Gamepass on PC.  I have looked in the event viewer did not see much in there .  but do have a lot of errors about opening a log file

svchost (25024,R,98) TILEREPOSITORYS-1-5-18: Error -1023 (0xfffffc01) occurred while opening logfile C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\EDB.log.

Here is a shot from BlueScreenView of the dmp file it created on crash.

T50RRNn.png

I have tired reinstalling to no avail.

Edited by Grex
Link to comment
Share on other sites

I have that same error.

Have you run the system integrity check like I described and seen if that makes any difference? Full instructions are at https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker.

Since you seem to know your way around Windows, do you get any useful information from the dump file when you examine that memory address? I wonder what command is being run... (info on how at https://www.tenforums.com/tutorials/5558-windbg-basics-debugging-crash-dumps-windows-10-a.html).

Link to comment
Share on other sites

Yeah i ran sfc /scannow which did say there were some corrupted files and that it could not repair them all.  So i ran the following
 

dism.exe /online /cleanup-image /scanhealth

dism.exe /online /cleanup-image /restorehealth

dism.exe /online /cleanup-image /startcomponentcleanup

and restarted the PC.  Still crashing.

I cleared my event log.  Nothing is showing in the application log when it crashes just the system log. 

I cannot get windbg to load the symbols so trying to figure that out.  But as seen in the BlueScreenView the crash is cause by CI.dll which is some code integrity check. I have other games installed in Xbox Gamepass installed they are working fine.

Link to comment
Share on other sites

@Dorgrin  I was able to get WinDbg to work and attached my bug check analysis.  Double fault - stack overflow.  Cant really tell what is causing it.  Not sure if you can see anything i cant. 

 

Once thing i did notice is the Mozyfilter module.  that should not be there.  I removed that software a long time ago.

OuterWorlds stack dump.txt

Link to comment
Share on other sites

Its seems that was the issue.  That rouge driver.  Somehow when the game ran it called that driver which was still listed as a service in teh registry but did not actually exisit anymore cause i uninstalled the sw. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...