Jump to content
  • 0

Black Screen At Arena Sub-level in Engwithan Digsite



When I try to go into the Arena Sub-level, the game will try to load it, but then I'm met with a black screen with nothing but the cursor and music playing (which also eventually stops).

I have tried everything to get this to work - I've verified the file integrity (twice), uninstalled and reinstalled (twice), updated my graphics card drivers, run this on a lower resolution, etc. Nothing has worked and I can't advance this game any further because of it. The game was working perfectly fine up until this point (some minor annoyances with performance, but overall, nothing game breaking for me).

Here's my output log: https://www.dropbox.com/s/t1afjid584ynhnn/output_log.txt?dl=0

Thank you!

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Same problem. Since this is a game breaking bug, it should have high priority in my opinion.


I tried the lowest graphics settings, as well as starting with and without importing POE1 saves - the game still hangs up while loading the arena beneath the Engwithian Ruins (the cursor appears and then it freezes).


Here is another save game and my dxdiag to speed up the fixing:





Also, and this may be related, loading saves from the Engwithian Ruins also often freezes the game in the same way.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...