Jump to content
  • 0

[Input Device] Mouse click doesn't work mostly


purluno

Question

1. A brief summary of the bug.

 

Most click failed to interact with Game UI.

2. A screen shot of the bug.

 

YouTube:



3. Detailed steps of how to reproduce the bug.

 

1) Start the game

2) Click

4. A save file from before the bug occurred.*

 

None

5. An output.log file.**

 

See an attached file

 

output_log.txt

  • Like 9
Link to comment
Share on other sites

Recommended Posts

  • 0

Aye, same here Prest. No issues outside of that, bar a few dialogue chains being a bit fickle at times. 

Seems to be when you're left clicking, it tends to stick, as if it's been half a click, click to select a character and rather the selection going through, it acts as if you're wanting to drag the portrait. If anyone has a fix in mind, much thanks would be sent your way.

Going through my GPU driver to make sure it's not interfering in some odd way, will post again if it clears it up.  

Link to comment
Share on other sites

  • 0

I am having the exact same issue. I thought I was going crazy. Was there any updates to game code today?

 

Basically, mouse sticks on clicking menu buttons, quickbar buttons etc. Makes the game pretty unplayable, especially since it affects combat.

 

 

Edit: Also, this is not an intermittent issue. It is happening constantly. 

 

I have tried swapping out three mice, multiple reboots and nothing. This issue started happening this morning, and I have dozens of hours in without issue prior to today.

 

Update: Disabling steam overlay seems to have corrected this issue, so it may be a good workaround for now.

Edited by iceferret
  • Like 1
Link to comment
Share on other sites

  • 0

 

Thank you to the folks that advised turning off steam overlay - that fixed the issue.  I was literally banging my head against the wall in frustration.

 

I'm experiencing this issue as well.   I can reproduce it on every click.  To make a click fail you press LClick or RClick down then you move the mouse  before releasing the click.  If you drift more than a little bit, the different X,Y positions usually result in the click having no effect.  It comes up a lot for me  when I am trying to react quickly to events.        

The easiest demonstration of this is on the start screen where you can click the Continue button to load the last save,  you can click down and see the continue button get visually pressed down, then move the mouse to another position on the Continue button and release - the Continue button will raise back up without triggering the actual event.  It's pretty annoying that you can trigger this problem without exiting the click region for the desired action  (like a character's portrait or a skill)

 

 

it looks like you guys can fix it by making the permitted distance between the down'n up larger & ignoring the distance entirely if the upclick is in the same region as the downclick

 

No idea if the beta fixes this,  I was not able to find a beta access code for steam.

 

 

Are you guys just reading the first page? 

 

Just right click on the game in steam and click on settings.  Now click Betas. And here select the Beta Branch.  I really hope the patch will go soon out of Beta. So many duplicated bug posts :x

 

 

I did read the first page, yes.  Eliminating the steam overlay is faster than downloading the Beta.  I'll get the patch when it comes out.  This was a post in an existing thread that I did not feel was duplicative at all - it was a thank you.  Don't get your panties in a bunch.

Link to comment
Share on other sites

  • 0

I had the same problem this morning, with buttons sticking. I logged out and saw there was an update for Pillars 2. So I downloaded that update and it fixed the button issue, but it created a new one: I can no longer scroll the screen with the mouse at the edge of the window. Scrolling vertically works; scrolling left/right does not. 

Link to comment
Share on other sites

  • 0

For those who still don't know, just disable the steam overlay for the game by right clicking on it in the steam library and go to properties. This issue is most likely due to the latest Steam patch because the problem started right after it updated it.

Link to comment
Share on other sites

  • 0

Yeah. The solution to this problem is to disable your steam overlay. Not only does it fix the problem, it fixed long loading times and lag for me as well.

Thanks you! That really fix my problem! But I still having long loading time though :D

Link to comment
Share on other sites

  • 0

Just a little info from me, i can get to a point the mouse click won't work at all.

 

But I have tab highlight set to the middle mouse button (the mouse wheel which I click so I don't gotta press tab if im drinking or something)

 

And if I middle mouse button click and THEN left click when the bug occurs it fixes it temporarily (at least for that mouse click)

 

Just a little insight if that helps fix the problem.

Link to comment
Share on other sites

  • 0

Hello all, I am having a similar issue. My issue is happening in the game. Mostly when I am in battle, for instance, on my Paladin, when I click on her Zeal power and the smaller window rises up and then you click on the spells/abilities there, say Lay on Hands, or any of them. The small window immediately closes. It will do this three or 4 or more times before the small windows that pops up from my mouse hovering over the Helmet Icon (for paladins) will stay long enough for me to click the spell/ability. Sometimes, not very often, I will have to select the power/spell twice before the game will register it. I have to constantly use pause to give me time to constantly make the spell window action bar pop up and 'stay up' long enough for me to actually click on it. This doesn't just happen on my Paladin, this happens on every character in my group. My battles take an inordinately long time as most of my time is spent just trying to get the action secondary bar, that rises up from the main (always showing abilities bar), to stay up. 

 

I just clicked download the beta and disabled the overlay of Steam. I am going to start the game and see if this works. I'll edit this if it works.

 

Thank you for your time.

Mereinid

 

*EDIT* Okay, I have been playing for about 6 or so hours now, the mouse clicking problem is still there. The pop-up action bars from my characters 'main' action bar is still not letting me click on them. They pop up and immediately sink back down. I have to try to catch the action skill/spell/ability with a click before it goes up and back down. Sometimes with me moving my mouse up and down, the pop-up bar will stay and I click the action easily, but never, ever, on the first two or three and sometimes 4th & 5th tries. I can't tell you how many times I miss clicking on the action button and then click on the map and send my character running off in some random direction. It's so fricking aggravating. If I wasn't a backer and loved the game so much I would have uninstalled it and waited a year or so and came back to see if it had been fixed or not...haha.

 

Anyway, that's all I have, I'm off to bed. Have a good night all.

 

 

Mereinid

Edited by Mereinid
Link to comment
Share on other sites

  • 0

I bought a utechsmart venus mmo gaming mouse and after I load the game I can't even click on the main screen buttons. i.e. new game/continue/load/options/credits/exit ect. they highlight make click sound but nothing happens.  mouse before that was a razor gaming mouse just had the usual problems reported previously.  Mouse works fine in windows and any other game I load. 

 

***update*** 

 

i had to edit the file dxgi.ini in F:\SteamLibrary\steamapps\common\Pillars of Eternity II

section [Window.system] borderless=true

and under [display.output] forcewindowed=true

 

then start the game and i could click on the main menus and go from there.

 

**new update*

 

after turning computer on this morning the issue is back. settings are still set.

 

going to the game executable location and running the exe as admin seems to have made it work better.

Edited by rothe123
Link to comment
Share on other sites

  • 0

I'm getting the same error just now and no solution works :(

Multiple clicks and a delay then a click registers. I've tried windowed/full screen/disabled steam overlay etc, same issue. What to do?

Edit: went round the issue by loading the game in administrator mode. A rather dangerous solution!!

Edited by Sovereign108
Link to comment
Share on other sites

  • 0

I have this bug with the last version (Obsidian Edition, all Dlc, 5.0)
If i run the game outside steam (with the exe on steamapps\common\Pillars of Eternity II) there is no problem (no need to execute in admin ) 

The problem appeared just after windows update (Windows 10, version 1903)

any idea?

Edited by Skeroujvapluvit
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...