Jump to content

Initial Linux beta feedback.


Recommended Posts

Hi,

 

First, thanks a lot to the folks who worked on making the Linux beta available. This is really great :).

 

I've spent a few hours with it, up until I got blocked by one semi-major bug (described in #2 below).  Feedback so far:

 

  1. The game is running pretty well (modulo bugs below).  No crashes, and performance is fine.
     
  2. [bug, save, major] - [Confirmed fixed in 3.0984] I've made a few saves, and the early ones load OK and restore their state as expected.  The last two, however, show the character creation GUI after I load them.  This temporarily blocked me from continuing.  I'll attach one of those as badsave.zip.  The same happens with the "Continue" button from the main menu.
     
  3. [Feedback, Writing] Even being a beta, the world is nicely immersive, as far as I managed to see before stopping due to #2 above.  Props to the writers.  The mute woman in the initial city with the drum, for example - I have no idea if she's part of a plot or merely a background NPC, but the interaction was poignant, yet pleasant.  It's not easy to do this stuff well, but my initial feeling is that the emotional tone of the world bodes well for the final game.
     
  4. [bug, UI, minor] [Confirmed fixed in 3.0984] In the auto-pause options, there are two "Low Health" checkboxes.  Unclear how or whether they differ.  The hover-text is identical.  See attachment LowHealth.jpg
     
  5. [bux, Gfx, medium] [Confirmed fixed in 3.0984] Just after entering the game, if I pan the view around, there's a stripe where some rock appears where water should be.  The width of the stripe changes as I pan.  I've attached two screenshots of this effect.  It appears to be either graphics from elsewhere in the scene, or possibly from another rendering layer.  See attachments GfxGlitch-1.jpg and GfxGlitch-2.jpg, both of the same effect, but showing how it changes with panning.  My glxinfo output is attached as glxinfo.zip.
     
  6. [bug, UI, medium] If I rebind keys, it almost seems like they perform both the action I rebound them to, and some other action.  For example, I've bound "Highlight Interactables" to keypad num5.  Pressing it indeed highlights interactables, but it also de-selects all but one character.  That doesn't happen if I bind H.I. to another key.  Also, if I map H.I. to keypad num0, then it both highlights interactables and changes the game to doublespeed.
     
  7. [uI, minor] The character creation hover-text works for some attributes, but not all.  E.g, there's no hover-text for dexterity on the Godlike screen, or Strength for Orlans, but others work.
     
  8. [Feedback, UI] Tentatively, I like the presentation of the character creation and level-up GUIs.
     
  9. [Feedback, Art] Art direction is always in the eye of the beholder, but I have to call DF out as being gorgeous.  POE1 was already very pretty, and this has raised the bar.  Deadfire may well be the nicest looking CRPG world I've seen, and by that I mean artistically so, not merely the kind of drenched-in-post-processing-effects nice that AAA games tend to have.  It's got a kind of honesty to its prettiness.  My one feedback here is: I think the game is already up against the limit of how much palette saturation looks good.  Any more and it'd be too cartoonish.  Even a touch less might be good.  That aside, incredible job by the artists and gfx programmers.  There are tons of nice touches: specular highlights from bits of rock, wave refractions, the new environmental effects, and the way heavier boats bob slower in the water than lighter ones.  I'm in love with the world already.
     
  10. [Feedback, Mechanics] I'm kind of heartbroken by what's happened to wizards, though admittedly I'm not very far along given my save-game issue above.  I won't belabor the points made in other threads, but at least I really hope you'll consider relaxing the restrictions around user-selected spell loadouts which aren't just the grimoire preselections.  Inability to pick my own combinations feels hugely stifling.  Some of the casting times look excessively long, too.  Given how much I love the Pillars world (see #3 and #9 above), this is a really rough one for me.  I always play wizard mains in CRPGs, and the POE2 semi-Vancian-class changes are ripping my heart out :(.
     
  11. [uI, minor] When entering the Subclass Selection screen for wizard, "No Subclass" was pre-selected, which is fine, but the right pane description doesn't appear.  Neither does it appear if I re-click "No Subclass".  However, selecting any other option such as Evoker, and then moving back to "No Subclass" makes it appear.  Minor thing, but it should probably be there upon entry to Subclass Selection.  Some people may never see it otherwise, if they accept the default.
     
  12. [Feedback, System] I have a multi-mon config, and the game properly launched on my main monitor.  I've seen other Unity games insist on launching on the first enumerated monitor, which for me is a tiny little side monitor.  Kudos for getting this right :).

badsave.zip

post-99369-0-41197300-1513902903_thumb.jpg

post-99369-0-02558300-1513903027_thumb.jpg

post-99369-0-59406500-1513903069_thumb.jpg

glxinfo.zip

Edited by demeisen
  • Like 1
Link to post
Share on other sites


  1. [bug, save, major] I've made a few saves, and the early ones load OK and restore their state as expected.  The last two, however, show the character creation GUI after I load them.  This temporarily blocked me from continuing.  I'll attach one of those as badsave.zip.  The same happens with the "Continue" button from the main menu.

 

​About that save-game bug, I've experimented some more, and I may have Sherlocked my way into a clue!

​First: I found that if I make a brand new game, create a char, enter the game, and immediately save, that save has the same problem.  Re-loading it bumps me back to the char creation screen instead of loading the save.  It seems I simply cannot make a good save outside of a building.

​So, I made an strace of this event.  I think I can ID the spot where things go wrong.  There's a place where a whole mess of portraits are loaded, which I assume is where the creation screen appears.  Just before that - exactly where I'd expect the problem to be triggered - I see this:

   write(17, "Fog of War: Failed to read file "..., 329) = 329
   write(17, "IndexOutOfRangeException: Array "..., 697) = 697
   write(17, "Failed to load fog of war line o"..., 166) = 166

​Maybe that IndexOutOfRangeException is being caught by something which falls back to the C.C. screen?  Or maybe it's a byproduct of that Fog of War read failure?  The fact that I can load a save from inside a building is consistent with that, no?  The inside save doesn't need to display the fog of war.  However all my outside saves don't work.

​I've tried re-installing the game from the installer, and that didn't change anything.

​Hope that's a useful hint for somebody! :brows:

  • Like 1
Link to post
Share on other sites

​Even more info:

The file it's failing to read is this, which exists:

Pillars of Eternity II Deadfire/game/PillarsOfEternity2_Data/exported/design/fogofwar/ar_0101_village_huana_ext.los

The game successfully opens that file - note file descriptor 46 here, which we'll follow:

open("/home/demeisen/Pillars of Eternity II Deadfire/game/PillarsOfEternity2_Data/exported/design/fogofwar/ar_0101_village_huana_ext.los", O_RDONLY) = 46
fstat(46, {st_mode=S_IFREG|0644, st_size=3406173, ...}) = 0

Then the game succeeds in reading the first 8K from the 3406173 byte file:

read(46, "... lots and lots of data...", 8192) = 8192

The file is closed before any more reads happen, so it appears something has gone wrong already, in the first 8K:

close(46):

then the error is reported.  Here's the full thing, with all the text from the out of range exception:

write(17, "Fog of War: Failed to read file /home/demeisen/Pillars of Eternity II Deadfire/game/PillarsOfEternity2_Data/exported/design/fogofwar/ar_0101_village_huana_ext.los. See the following exception.\n \n(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)\n\n", 329) = 329
write(17, "IndexOutOfRangeException: Array index is out of range.\n  at (wrapper stelemref) object:stelemref (object,intptr,object)\n  at Game.FogOfWarLOS.ReadVertData (System.IO.BinaryReader reader, Game.FogOfWarLOS data, Int32 maxVerts, Boolean isBackside) [0x00000] in <filename unknown>:0 \n  at Game.FogOfWarLOS.Load (System.String filename) [0x00000] in <filename unknown>:0 \nUnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)\nUnityEngine.DebugLogHandler:LogException(Exception, Object)\nUnityEngine.Logger:LogException(Exception, Object)\nUnityEngine.Debug:LogException(Exception)\nGame.FogOfWarLOS:Load(String)\nGame.FogOfWar:OnyxStart()\nOnyx.OnyxBehavior:Start()\n \n(Filename:  Line: -1)\n\n", 697) = 697
write(17, "Failed to load fog of war line of sight data.\n \n(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)\n\n", 166) = 166

Without source, I have no visibility into the processing of the LOS file, so I can't tug on the thread much more.  Well, I could probably debug it at the assembly level, but that'd be a proper pain in the posterior.
 

Edited by demeisen
  • Like 1
Link to post
Share on other sites
  • 1 month later...

​​For what it's worth, I can confirm that the above problem #2 about resetting to the char creation screen on zoning is fixed in "v0.0.0.0052 Backer Beta Release 3.0984 BB".  Thanks!

​Can also confirm #4 about two identical auto-pause options is fixed.

​Edit: #5, about bad rendering near initial water, also appears to be fixed as far as I've looked, although that's only for a few minute so far.  (And it's nice!  The splashing of waves on the rocks, the water translucency, it just all looks amazing.  Although I'm not a fan of some of the combat system changes in DF, I plan to play the game just to see what your artists have made).

​I still see issue #6, with certain keybindings performing two tasks, the one I want (such as highlighting interactables) and one I don't, such as toggling fast mode.

Edited by demeisen
  • Like 1
Link to post
Share on other sites

Hey demeisen!

 

Thank you very much for this in depth feedback post! I'll take a look at the bad saves you have sent, but most of this stuff is currently being worked on (I think we may already have a fix for the save issue), and as you have expressed, much of this is still being worked on, so stay tuned for future updates, and I will pass this info along to the devs :)

 

You the best,

 

-Caleb

I like big bugs and I cannot lie...

Link to post
Share on other sites

​Thanks Cdiaz, but also note my update above: the latest beta fixed the problems with bad saves (and several others I saw), so I don't think there's any more need to waste someone's time to look at that one.  It works now :)  Editing to add: updated original post with that info.

There's still a minor issue with keybindings, though.

Edited by demeisen
Link to post
Share on other sites
×
×
  • Create New...