Jump to content
  • 0

Character particle effects suddenly became messed up.



Hello, and sorry for being the bringer of bad news on my first post.


I've posted this same post to the game's steam forums, but I got no reply there, so I am posting it here as well, in hopes of getting it resolved.

Basically I came back to the game after taking a break from it and buying The White March pt. 1, also having updated to Windows 10. I created a new game, exited for a different kind of playthrough with all self-made party, but something has happened to the character particle effects, they've become blocky, really low-res and misshapen with very low color count. I tried disabling Vsync to no avail, and fiddled with most of the other graphical settings. So far I've seen this problem with torches of the characters, and chanter chanting effect, I would presume other magic too.
Admittedly I run an older graphics card, GeForce GX430 series if memory serves, but previously everything was fine when I played. I've also installed the latest Nvidia drivers recommended for my setup and OS.

I added my output_log.txt to this post, but not the savegames for now, please do ask if you need me to add any other information.

Anyone else had this problem, and any suggestions how to fix this. of course, hopefully this will be identified by the devs and ironed out on next patch, but it is a touch distressing and disappointing when I wanted to enjoy the game now.

Thank you so very much <3


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello Thullmar,


Welcome to the forums and thanks for joining us! As you probably guessed, updating to a new OS can complicate thing. Just make sure that you update all of your drivers and run Windows Update multiple times. 


Also on Steam, please verify your game cache and see if that helps as well. In your Steam library, right click PoE > Properties > Local Files > Verify Integrity of Game Cache.



  • Like 1
Link to comment
Share on other sites

  • 0

Thank you! And thank you for the warm welcome :)

For some reason I keep forgetting Steam has the capability to Verify and fix game cache, even though I've repeatedly used said tool to try and fix problems with games from certain other legendary RPG company, perhaps starting with "B". Makes me feel like a complete moron.

But steam's Game Cache Integrity tool indeed did fix the problem, and I can see no more in sight.

So thank you again for speedy reply that promptly fixed the problem, 10/10 customer service :)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...