Jump to content
  • 0

Ondra's Gift is covered by water.


zhen

Question

At the Ondra's Gift I only see the water, nothing else.

 

The first time I entered the Ondra's Gift everything was right. I found the dead boy and told his mother. After I exit the mother house, all the map is covered with water.

 

I attach two images of what I see now.

 

I exit the game and enter it again, but the problem remain. Everytime I comeback to Ondra's Gift all is water covered.

 

I'm using Steam on Linux.

 

uname -a
Linux tormekia 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
 

System Info:

Lenovo ideapad z510

Linux Mint 17 Cinnamon 64-bit

Cinammon version 2.2.16

Kernel  3.13.0-24-generic

CPU Intel Core i7-4702MQ 2.20 x 4

Memory 7.7 Gb

GPU NVIDIA Corporation GK208M [GeForce GT 740M]

 

post-47257-0-36033500-1428760308_thumb.jpg

post-47257-0-75611900-1428760318_thumb.jpg

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

From https://forums.obsidian.net/topic/74020-ondras-gift-completely-submerged-linux/?do=findComment&comment=1622925

...

Option 1: open a console/terminal and start the shell-script with 'LANG=C ./shell_script'

Option 2: edit the shell script and add the line 'LANG=C' somewhere above where it starts the main executable

If you have a desktop shortcut to start the game you can edit that one instead, but since I don't know which desktop you use I can't give you detailed instructions how to do that.

 

To elaborate the problem, game resources stores some values with a decimal point ( example 1.45 ), now the game reads that value out of the resources on your hdd, your localisation defaults to a language which uses a commata instead of a decimal point ( so value should be 1,45 ) but since its stored with a point the read on the value transforms it to 145 since there is no commata. With the environment variable LANG you tell the program to disregard your default language setting and fall back to english with a decimal point.

 

 

Cail The Silent- The drake coils its body protectively around something. "One day I will become a burning thing. Bright and terrible like my spark."
Quest "Cinders of Faith"
 
Sagani- Sagani chuckles. "Nothing against these stuffy forests, but you haven't seen the southern lights over Naasitaq."
Quest "The Long Hunt"

Link to comment
Share on other sites

  • 0

Thanks!,

 

Setting the enviroment variable LANG solved the problem.

You're welcome!

Cail The Silent- The drake coils its body protectively around something. "One day I will become a burning thing. Bright and terrible like my spark."
Quest "Cinders of Faith"
 
Sagani- Sagani chuckles. "Nothing against these stuffy forests, but you haven't seen the southern lights over Naasitaq."
Quest "The Long Hunt"

Link to comment
Share on other sites

  • 0

I realize this isn't helpful, and I'm sorry, but this is hilarious. :lol:

 

Yeah, i browse the bug reports here, and i was thinking the exact same thing. Some of the bugs are... well, you know :D. I pity the obs guys. Should not be as fun for them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...