Jump to content
  • 0

Black screen when after loading a map



Hi there


Sorry for the title not very explicit.



Let me explain better : i'm in Raedrick's fortress, i just talked to Nedmar who gave me the key to open the door (with a high level lock) to go kill Raedrick.


Behind this door there's a very small corridor which leads to a staircase which leads to another map.


So it loads the map but as soon as the loading screen is finished, the screen turns black and i still can move my mouse !!?


The cursor is sometimes a finger (like when you search a safe in game), sometimes an interdiction (like in game, places you can't go), and sometimes simply the icon which let you know you can move your characters here.


Music plays normally.


I tried full screen and window : same problem.


I guess there's a scene my computer don't wanna play so it stays black.



Well fortunately or not i have a save right in front of it.


HELP please ;(

  • Like 2
Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

I am also having this problem, it has shown up when I enter the Inn in Guilded Vale, and when I go upstairs in Brighthollow in our stronghold. This happens after the end of Act 2. 


In both cases, it prevents me from being able to rest at either the Inn, or my own stronghold. 


The loading screen progresses as normal, and then loads to a black screen, where I can hear music, sometimes ambient noise, and the mouse cursor. The HUD doesn't load, nor do any of the graphics. 


I have tried loading earlier saves, to the point that I played back an hour or two to test whether it would still occur. 

Link to comment
Share on other sites

  • 0

I have the same problem with the Keep.


When I try enter the "kitchen" area, or go in with the big main door I just get a blackscreen.


Posted this on reddit also, here is the text from that, with some more info about what I tried.


"Hello, first of all I just want to say I love the game.

Now to my problem, I'm working on the quest to take down Raedric, I have more or less cleared all of the castle. I started by climbing the side of the wall, killed most stuff, entered the temple/priest part, then went down to the kitchen, there I got stuck by the big door didn't have key/mechanics enuff. I went outside and killed some more stuff, I then found the 2nd way in with the sewer, I chose to kill the "Necromancer" down there and couldnt open the big door down there (not sure if I missed the key, or if that's the way you get in, if you help her).

Anyway at this point I thought that I should return to the kitchen area since I saw that I had a big key in my questitems, and also it's the area that I might have missed something in.


Now for the problem, when I click on the staircase down to the kitchen I first get the loadingscreen then everything goes black, I get the cursor but its the red "stop" sign, I can move it around but it's just black, if I do any mouseclick I get a "windowserror" that PillarsOfEternity doesn't respond anymore.

I have no clue how to go around this.


Right now if I just press Continue (and thus load the autosave down to the kitchen) the same thing happens, I have a quicksave more or less just outside that part and if I load that the game works but if I go down, I get the same thing again.

Is this a known problem? Can I send my savefiles to some support and have them look at it?

Thanks in advance, not sure if I should just skip the quest and do other stuff, but then again I want to finish this, feels like a big quest.

EDIT: I just thought that what if I enter from the frontdoor, so I tried that and same thing happens."


Link to comment
Share on other sites

  • 0

I have the same issue, at the start of Act 3. Just after the little "act intro" with the rolling text I get a loading screen (no problems there, as far as I can see), and then just a black screen with a cursor. 


It's really annoying, especially since I'm more or less done with the available side quests and therefor don't really have anything to do while waiting for a solution. :/

Link to comment
Share on other sites

  • 0

Guys, there are already a few threads about Raedric's Hold being bugged. No need to open another one, discussing exactly the same questions. Let's keep it centralized...


While I agree having several open threads on the same topic is unnessecary, I think it's worth noting (as this thread does) that the problem isn't only in Raedric's Hold. It seems like more people are having trouble there, but it's an issue at several locations. I had no problems whatsoever in RH, but now can't progress to Act 3 because of the same bug. 


 \Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\output_log.txt

look it after black screen, is there anything about chants?

have u chanter in party?


Why would a Chanter matter? Removing my Chanter did absolutely nothing for me. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...