Jump to content
  • 0

[issue] Scrolling with dual-monitors


LiquidThunder

Question

So far, I am loving this game.  However, one problem did jump out at me at the start.  I use a dual-monitor set up and unlike in most games, having Pillars of Eternity full-screen does not appear to "lock" my cursor on to my left screen (where I play my games).  This makes it very difficult, if not impossible, to scroll right by moving my cursor to the edge of the screen as it simply moves into my other monitor.

 

This is a rather minor issue, but I would greatly appreciate it if it was fixed at some point.  Thanks!

  • Like 3
Link to comment
Share on other sites

Recommended Posts

  • 0

I don't know if this helps identify the cause of the issue devs, but another way to "fix" Cage Cursor is for me to enable full screen and then enable window mode again in my graphics options.

 

I'm using:

Dual monitors both set to 1920X1200

GTX 780

Windows 7 x64 SP1

344.75 (Nvida Driver version)

 

Looks like I'm out of date on my graphics driver, I'll fix that.

Link to comment
Share on other sites

  • 0

 


However, one problem did jump out at me at the start.  I use a dual-monitor set up and unlike in most games, having Pillars of Eternity full-screen does not appear to "lock" my cursor on to my left screen (where I play my games).

You dont want to be the cursor locked, since it will make it harder to easily switch to other windows.

Why dont you just scrolling with the keyboard? Works perfect.

Link to comment
Share on other sites

  • 0

 

However, one problem did jump out at me at the start.  I use a dual-monitor set up and unlike in most games, having Pillars of Eternity full-screen does not appear to "lock" my cursor on to my left screen (where I play my games).

 

You dont want to be the cursor locked, since it will make it harder to easily switch to other windows.

Why dont you just scrolling with the keyboard? Works perfect.

 

 

Umm no, clearly you do not have multiple monitors.

This bug is extremely annoying. If it is not locked, it is pretty much impossible to scroll to the right side of the screen, because your mouse will fly off to your second monitor. It doesn't make it easier to switch to other windows at all, that's what alt-tab is for.

 

And scrolling with the keyboard? Are you serious here? Imagine if they removed mouse scrolling from the game entirely and said you can only scroll using a keyboard. Do you know how hard they would get bashed in the reviews for an utterly clunky camera control mechanic?

 

I am all for defending a great game, but come on, you can't wave this away by saying just use the keyboard.

Link to comment
Share on other sites

  • 0
This bug is extremely annoying. If it is not locked, it is pretty much impossible to scroll to the right side of the screen,...

To me its the left side, my gaming monitor is on the right side.

 

 

 

 

Umm no, clearly you do not have multiple monitors.

*Lol* dude I've multiple monitors for years..

 

My current X11 setup:

 

Screen 0: minimum 8 x 8, current 2960 x 1050, maximum 16384 x 16384

DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024     60.02*+  75.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 1680x1050+1280+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050     59.95*+
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  

DP-1 disconnected (normal left inverted right x axis y axis)

 

 

Im sorry to confuse you but Im scrolling with key arrows since the Infinity games, it worked very well to me.

 

 

Imagine if they removed mouse scrolling from the game entirely and said you can only scroll using a keyboard. Do you know how hard they would get bashed in the reviews for an utterly clunky camera control mechanic?

But if your dual monitor setup is faulty, then its not the game to blame... with a single monitor you wouldnt have the issue. ;)

Edited by mega-T
Link to comment
Share on other sites

  • 0

I have a similar, though not quite the same issue. Here's a screenshot of both monitors. The left is in portrait mode and the right (primary) is landscape. http://mindkeep.org/public/Screenshot_2015-03-28_13-16-47.png

 

My monitor setup is something like:

22

221111

221111

22

 

Where 1 is 1920x1080 and 2 is 1050x1680. (Awesome for coding on the left monitor by the way.)

 

The upper and lower left corners are non visible space (just whatever happens to be hanging around the buffer).

 

The problem is that Pillars seems to be trying to use the whole 2 monitopr space (and failing at it) while most games in full screen mode will maximize to the right monitor without issue. I think the root of this is Grestorn's post:

 

Is there any way to force the game to use a real fullscreen mode instead of the borderless window mode it uses by default?

 

Reason: I might want to use DSR (Dynamic Super Resolution) and/or GSync. Both of which are only available in fullscreen mode.

 

Whatever Pillars is trying to do here is probably overcomplicated and it should just be using the ffullscreenmode instead of rolling it's own solution. (Or at least give us the option so we can fiddle the nobs until it works.)

 

I can't even see the Graphical options to try and fix this on my linux desktop, because most of the dialog is not visible on the screen.

  • Like 1
Link to comment
Share on other sites

  • 0

I'm also having this issue, the cursor cage is removed after an in-game cut scene or certain conversations. I've found that a quick way to re-enable the cursor cage is by alt+tabbing in and out of the game, instead of going into the option menu every time.

  • Like 1
Link to comment
Share on other sites

  • 0

For a temporary work-around, you can re-position your second monitor in the Resolution config in Windows.  Just join them at the corner so that there is a tiny gap of overlap between the sides, so that you can still move your mouse cursor to the other window.  

 

Also, you'll still be able to move applications between monitors by using Windows Key + Direction Key (left or right).  

 

Here is a screenshot example for how to line up your monitors:

 

http://imgur.com/XK3D7ua

Link to comment
Share on other sites

  • 0

I have a similar, though not quite the same issue. Here's a screenshot of both monitors. The left is in portrait mode and the right (primary) is landscape. http://mindkeep.org/public/Screenshot_2015-03-28_13-16-47.png

 

My monitor setup is something like:

22

221111

221111

22

 

Where 1 is 1920x1080 and 2 is 1050x1680. (Awesome for coding on the left monitor by the way.)

 

The upper and lower left corners are non visible space (just whatever happens to be hanging around the buffer).

 

The problem is that Pillars seems to be trying to use the whole 2 monitopr space (and failing at it) while most games in full screen mode will maximize to the right monitor without issue. I think the root of this is Grestorn's post:

 

Is there any way to force the game to use a real fullscreen mode instead of the borderless window mode it uses by default?

 

Reason: I might want to use DSR (Dynamic Super Resolution) and/or GSync. Both of which are only available in fullscreen mode.

 

Whatever Pillars is trying to do here is probably overcomplicated and it should just be using the ffullscreenmode instead of rolling it's own solution. (Or at least give us the option so we can fiddle the nobs until it works.)

 

I can't even see the Graphical options to try and fix this on my linux desktop, because most of the dialog is not visible on the screen.

 

If you are using KDE4, this can be easily customized - for each window/application.

See KDE4 system settings -> window behaviour -> window rules.

For my window I've set the position offset to 1280,0 (because my first monitor has an max. X res of 1280) - if correctly configured the window will then always appear on the second TFT.

Link to comment
Share on other sites

  • 0

 

But if your dual monitor setup is faulty, then its not the game to blame... with a single monitor you wouldnt have the issue. ;)

 

Oh, PLEASE tell me you don't actually believe that! It is defnitely the game to blame. When multiple people are having the problem, it's a problem with the game, not the user's setup.

 

The game is not using a true full screen. When I play, my taskbar shows up at the bottom of the screen. That does not happen with true full screen games.

 

This is an issue with the game, and it looks like Obsidian will be looking into it, which is great.

 

But don't blame the users. It's not our fault. You just look silly when you say something like that.

 

Cant EDIT: replaced a word to convey the same idea with hopefully less provocation. Please attack each other's arguments and not each other's person.

Link to comment
Share on other sites

  • 0

May I recommend the free tool Cursor Lock?

http://www.snakebytestudios.com/projects/apps/cursor-lock/

 

It works perfectly and I'm using it for almost 8 years, since I had my first dual setup with two 1600x1200 21' monitors.

It runs so flawless that I have added it to my autostart folder and just toggle it on/off via a global hotkeys. Plus it allows you to switch modes to restrain the cursor inside windows borders/ outside windows border (for edge scroll) or lock it down to a screen. Additionally you can create shortcuts to start games with cursor lock activated, and have it disabled if you task switch.

  • Like 1
Link to comment
Share on other sites

  • 0

 

But if your dual monitor setup is faulty, then its not the game to blame... with a single monitor you wouldnt have the issue. ;)

 

 

Nothing you've posted is a solution, not even on linux.  Randomly posting multi-monitor setups does not help at all.  The issue is in game.  It's a sadly common issue in many recent games that always gets addressed after launch.

Link to comment
Share on other sites

  • 0

 


The game is not using a true full screen. When I play, my taskbar shows up at the bottom of the screen. That does not happen with true full screen games.

Well these things are handled different on Windows or Linux (I cant talk for MAC), but you do know that on X11 true fullscreen would rather break the idea of dual-monitor setup.

On X11 the screen is combined of both monitors, so only a rare handful of people really want fullscreen mode (which would render the game on both monitors, or even multiple monitors).

Link to comment
Share on other sites

  • 0

 

The middle mouse button is great though, nice to see that unlisted command.

 

It's actually listed on page 12 of the manual chapter "Default Controls" subsection Mouse Controls. ;)

 

 

Middle-click, Hold, and Drag

• Pans the camera.

Edited by Dragoon-
Link to comment
Share on other sites

  • 0

I can confirm this is also occurring on my dual monitor setup (Intel i5 and AMD graphics). 

The mouse cage will fail following most instances of conversation, story sequence, or pretty much any time control is taken from the player for one reason or another.

I can also confirm that quickly alt-tabbing out of the game and then back works to re-engage the mouse cage. 

Lastly, I would like to mention that the Cursor Lock, as mentioned by Dragoon- worked perfectly for me as a workaround. Installed it in a few seconds, there does not seem to be any bundled crapware, and it does it's job well. For me at least, this is the solution, for now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...